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1. Komputer I. Judul

\— J

Kata
Pengantar

Puji syukur kami haturkan ke hadirat Tuhan Yang Maha Kuasa, karena
atas anugerahNya kami bisa menyelesaikan pembuatan buku Panduan
Lengkap Mengelola Proyek dengan Microsoft Project Professional 2007
ini. Kami juga berterima kasih atas dukungan dari keluarga dan rekan-
rekan sejawat dalam mendorong kami untuk senantiasa maju dan salah
satu perwujudannya adalah dengan adanya buku ini.

Buku ini kami buat didasari minat yang cukup tinggi dari dunia akademik
dan dunia usaha akan suatu perangkat lunak untuk mengelola proyek yang
sedang dijalankan agar tepat waktu dan tepat anggaran dan juga minimnya
referensi aplikasi ini. Selama ini kebanyakan orang#henganggap MS Project
hanya dipergunakan untuk membuat jadual saja, padahal masih banyak
fitur-fitur lainnya yang bisa dimanfaatkan untuk memudahkan pekerjaan
manajer proyek ataupun pekerja-pekerja lainnya yang terlibat dalam
proyek. Dasar lain dari keinginan membuat buku ini adalah minimnya
buku yang membahas MS Project, khususnya MS Project 2007. Buku-buku
yang membahas perangkat lunak Microsoft Office lainnya yang populer
seperti MS Word, MS Excel, dan MS Power Point sudah sangat banyak,
sedangkan buku yang membahas MS Project masih dapat dihitung dengan




jari. Diharapkan buku ini dapat menambah referensi dan pilihan bagi siapa
saja yang ingin memantaatkan aplikasi ini dengan baik dan efektif,
Penyusunan buku ini kami rancang sejelas mungkin agar dapat diikuti
oleh pemula meskipun tidak meninggalkan pembaca yang sudah memiliki
pengalaman dengan MS Project. Tidak lupa kami menyisipkan beberapa
materi manajemen proyek saat membahas fitur-fitur tertentu di aplikasi
ini agar lebih menambah wawasan ilmu dari pembaca. Penyusunan dari
pembahasan buku ini juga disesuaikan dengan tahapan yang biasa dialami
oleh sebuah proyek yaitu mulai dari tahapan pendefinisian, tahapan
perencanaan, tahapan eksekusi yang dibarengi dengan proses pelacakan,
dan diakhiri dengan tahapan penutupan proyek. Pada bagian akhir kami
menambahkan fitur lanjut dari MS Project 2007 yang mampu untuk
mengelola berbagai proyek secara bersamaan. Contoh kasus yang kami
pilihkan dalam pembahasan buku ini adalah kasus pembuatan rumah dan
perumahan yang kami buat agar lebih mudah dipahami oleh pembaca,
meskipun MS Project 2007 bisa dipergunakan untuk mengelola berbagai
macam proyek yang lainnya.

Penulis menyadari bahwa pastilah terdapat banyak kekurangan dari buku
ini. Apabila pembaca menemukan kesalahan atau saran perbaikan kami
dengan sangat terbuka menerimanya. Saran dari pembaca dapat dikirimkan
ke alamat email kami awreman@yahoo.com, ymd261@yahoo.com, atau
hapnestoba@yahoo.com

Yogyakarta, 11 November 2009
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Bah1
Pengenalan Manajemen Proyek

etiap hari dalam kehidupan sehari-hari kita sering melihat berbagai

macam pekerjaan yang dapat dikategorikan sebagai proyek. Misalnya
proyek pembuatan rumah, proyek pengaspalan jalan, proyek pembuatan
laboratorium komputer, dan lain-lain. Meskipun proyek satu dengan yang
lain terlihat sangat berbeda, namun secara umum sebuah proyek memiliki
beberapa karakteristik yang sama:

*  Merupakan urutan kegiatan-kegiatan (zasks) dengan awal dan akhir
yang jelas, di mana kegiatan-kegiatan tersebut bisa berjalan berurutan
ataupun paralel.

*  Membutuhkan sumber daya (resources), baik yang berupa sumber daya
manusia (pekerja), sumber daya material, maupun biaya.

*  Mencapai tujuan (objectives) yang biasanya sudah ditetapkan sejak
awal bahkan sebelum proyek tersebut dimulai.

*  Menghasilkan sesuatu yang baru (unigue purpose) yang berbeda antara
proyek yang satu dengan proyek yang lain.



Manajemen Proyek adalah proses perencanaan, pengorganisasian, dan
pengaturan  kegiatan-kegiatan dan sumber daya-sumber daya untuk
mencapai suatu target prestasi tertentu, biasanya dalam batasan waktu,
sumber daya dan biaya. Suatu rencana proyck dapat berupa sesuatu yang
sederhana, seperti daftar kegiatan-kegiatan dan waktu mulai dan selesai
yang ditulis di dalam buku catatan. Atau dapat juga berupa sesuatu yang
kompleks contohnya ribuan kegiatan dan sumber daya dan anggaran yang

mencapai jutaan dollar.

Kebanyakan aktivitas di dalam proyek memiliki kemiripan, di antaranya
memecahkan proyek ke dalam kegiatan-kegiatan lebih kecil yang dapat
diatur dengan lebih mudah, penjadwalan kegiatan-kegiatan, komunikasi
dengan tim, dan memonitor kemajuan dari kegiatan-kegiatan yang
dijalankan. Semua proyek pada dasarnya terdiri dari 4 fase utama yaitu:

1 Pendefinisian Project (Project Definition)

2 Pembuatan Rencana Proyek (Project Planning)

3 Proses Eksekusi/Pelaksanaan Proyek (Project Execution), di mana
fungsi manajemen proyek di sini adalah melakukan pengamatan dan
pengaturan proyek (Project tracking and Controlling)

4 Penutupan Proyek (Project closin 9)

Waktu pelaksanaan ke empat fase di atas dinamakan sebuah siklus hidup
proyek (Project Life Cycle) yang biasanya intensitasnya pada awal berjalan
lambat dan membutuhkan sumber daya yang sedikit dan kemudian terus
meningkat dengan intensitas dan penggunaan sumber daya yang tertinggi
pada saat proses eksekusi proyek. Pada proses penutupan proyek intensitas
dan penggunaan sumber daya akan kembali menurun seperti yang terlihat
pada gambar 1.1.
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Gambar 1.1 Intensitas Sepanjang Siklus Hidup Proyek

Dari gambar 1.1 diketahui bahwa intensitas pekerjaan (yang berarti juga
penggunaan sumber daya terbesar) terjadi pada saat fase eksekusi proyek.
Ini bukan berarti fase definisi dan perencanaan bukan merupakan hal
yang tidak penting. Suatu eksekusi proyek akan tidak efisien dan bahkan
mungkin sia-sia apabila tidak didefinisikan dan direncanakan dengan baik.
Pada fase penutupan terjadi banyak proses administratif dan juga proses
pembelajaran hal-hal yang masih belum sempurna sehingga pada proyek
yang berikutnya akan menjadi lebih baik.

Pada gambar 1.1 juga digambarkan kegiatan kontrol yang merupakan
bagian dari manajemen proyek yang sangat penting. Proses kontrol ini
berlangsung sepanjang hidup proyek dan intensitasnya sebanding dengan
tingkat intensitas dari siklus hidup proyek itu sendiri.

1.1 Segitiga Proyek

Untuk dapat menangani sebuah proyek dengan baik, terdapat tiga hal
paling penting yang harus diperhitungkan oleh seorang manajer proyek:

«  Waktu (#ime): Waktu yang diperlukan untuk menyelesaikan proyek
tercermin di dalam jadwal proyek.

Pengenalan Manajemen Proyek H 3



= Uang (cost): Anggaran proyck, didasarkan pada biaya sumber daya- !

sumber daya: manusianya, perlengkapan, dan materi yang dibutuhkan
untuk melaksanakan kegiatan-kegiatan yang ada.

*  Ruang Lingkup (scope): Tujuan dan kegiatan-kegiatan dari proyek, dan
usaha yang diperlukan untuk menyelesaikannya.

Ketiga faktor membentuk suatu segitiga. Menyesuaikan satu dari ketiga
clemen ini akan mempengaruhi 2 lainnya. Sementara ketiga elemen ini
penting, biasanya hanya ada salah satu dari ketiganya yang akan sangat
mempengaruhi proyek yang anda kerjakan. Hubungan antara elemen-
elemen tersebut berbeda untuk setiap proyek dan menentukan tipe masalah
yang akan anda temui dan pemecahan yang dapat diterapkan.

Scope/Performance

Money

Gambar 1.2. Segitiga Proyek

Scorang manajer proyek harus mampu menciptakan keseimbangan antara

ketiga faktor pembentuk proyek. Lebih lanjut, tugas dan pekerjaan seorang

manajer proyek merupakan refleksi dari aktivitas manajemen secara luas,

yaitu:

1. Manajemen adalah proses menentukan dan mengimplementasikan
cara-cara untuk memanfaatkan sumber daya manusia dan non

manusia secara efektif dan efisien untuk mencapai tujuan yang telah
ditentukan
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2o Seorang, manajer proyck sepertinya tidak berbeda dengan manajer
fainnya,  yaitu  merencanakan, menjadwalkan, memotivasi dan
mengendalikan

3. lapi, scorang manajer proyek adalah unik, karena manajer ini hanya
mengatur aktivitas-aktivitas yang temporer, tidak repetitif, dan seringkali
bertindak secara independen di dalam suatu organisasi formal

1.2 Microsoft Project 2007

Scbagai manajer proyek, seringkali banyak sekali yang harus dilakukan
dengan cermat, tepat dan benar. Untuk itu maka sebuah perangkat lunak
dapat dipergunakan untuk membantu, yaitu Microsoft Project atau yang biasa
disingkat MS Project. Versi terakhir dari MS Project adalah Microsoft Project
2007 yang merupakan bagian dari Microsoft Office Professional 2007.

Adapun kemampuan dari MS Project 2007 adalah:

1. Menyimpan detail mengenai proyek anda di dalam database-nya yang
meliputi detail tugas-tugas beserta hubungannya satu dengan yang
lain, sumber daya yang dipakai, biaya, jalur kritis dan lain-lain.

2. Menggunakan informasi tersebut untuk menghitung dan memelihara
jadwal, biaya, dan elemen-elemen lain, termasuk juga menciptakan
suatu rencana proyek. Semakin banyak informasi yang disediakan,
semakin akurat rencana Anda.

3. Melakukan pelacakan selama proyek berjalan untuk menentukan
apakah proyek akan dapat diselesaikan tepat waktu dan sesuai
anggaran yang direncanakan ataukah tidak. Apabila proyek berjalan
terlambat atau anggaran sekarang telah melebihi dari yang seharusnya
maka seorang manajer proyek bisa melakukan beberapa langkah untuk
mengembalikan proyek sesuai jalurnya.

Seperti spreadsheet, MS Project 2007 memperlihatkan hasil perhitungan

secara langsung. Tapi, rencana proyek tidak akan selesai sebelum semua
informasi kritis mengenai proyek dan kegiatan-kegiatannya dimasukkan.

Pengenalan Manajemen Proyek & 5
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Setelah itu, baru Anda dapat melihat kapan proyck Anda selesai dan kapan
jadwal keseluruhan dari semua aktivitas benar-benar terlihat. M$ Project
menyimpan data yang dimasukkan oleh pengguna dan menggunakannya
untuk menghasilkan informasi spesifik seperti deskripsi kegiatan, jalur
kritis proyek atau lamanya. Dalam MS Project, setiap data dimasukkan
melalui fe/d, yang kemudian dapat dimunculkan melalui sebuah kolom.

1.3 Melihat Data yang Dibutuhkan di MS Project 2007

Hari ini, Anda berfokus pada tenggat waktu. Besok, pada biaya. Database
proyek terdiri dari berbagai informasi, tapi pada waktu tertentu, anda hanya
membutuhkan sebagian saja dari semua itu. Untuk mendapatkan hal-hal
tertentu tersebut, MS Project 2007 memiliki alat-alat berikut ini:

*  Views memperlihatkan suatu set informasi di dalam format yang
mudah diinterpretasikan. Pilihan views ini dapat dipilih pada menu
View dengan pilihan adalah sebagai berikut:

- Calendar: menampilkan daftar tugas-tugas beserta sumber daya
proyek dalam format kalender.

Gambar 1.3. Contob View Calendar
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Gantr Chars: menampilkan daftar tugas-tugas beserta sumber
daya dalam bentuk diagram batang horisontal yang panjangnya
menunjukkan durasi dari masing-masing tugas tersebut. View atau
tampilan inilah yang menjadi tampilan utama dan yang penting
dari MS Project 2007.

Network Diagram: menampilkan daftar tugas-tugas dalam bentuk
diagram blok yang berhubungan satu dengan yang lain. Tujuannya
untuk menunjukkan keterkaitan antara satu tugas dengan yang
lain dalam bentuk rangkaian tugas.

v e

;@s-

ry
an Tanak Pembuatal
ot YR IS Sart: 9208
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Res;_Mandor 1, Tukang Bat |__Res: Mendor
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Gambar 1.4 Contoh View Network Diagram

Task Usage: menampilkan detail penggunaan sumber daya proyek
pada setiap satuan waktu pelaksanaan proyek. Pembahasan lebih
mendalam di bab 5 dan bab 6 buku ini.

Tracking Gantt: tampilan yang mirip dengan Gantt Chart yang
sangat diperlukan saat melakukan pelacakan di sepanjang hidup
proyek untuk melihat status pelaksanaan proyek sampai dengan
saat itu. Pembahasan lebih mendalam tentang ini terdapat dalam
bab 7.

Pengenalan Manajemen Proyek ® 7



= Resource Graph: tampilan untuk melihat beban kerja dari masing
masing sumber daya (khususnya sumber daya pekerja). Ini sangat
bermanfaat pada proses Resource Leveling yang dibahas pada
bab 5.

= Resource Sheet: dipergunakan untuk mengisikan detil dari masing -
masing sumber daya yang dipergunakan oleh proyek. Pembahasan
mendalam terdapat pada bab 5.

= Resource Usage: dipergunakan untuk melihat detil penggunaan
dari sumber daya pada satuan waktu pelaksanaan proyek.

*  Tubles mendefinisikan kolom yang ingin diperlihatkan pada View
tertentu. Apabila kita memilih salah satu View yang ada, kita dapat
memilih kolom-kolom detail yang ingin diperlihatkan dengan memilih
pada bagian View > Tubles > Piliban yang ada.

*  Filtersberfokus pada kegiatan atau sumber daya spesifik untuk melihat
suatu bagian spesifik. Kita bisa memberikan fokus pada kegiatan atau
resources tertentu saat memilih suatu menu View dengan memilih
menu Project > Filtered for dan memilih salah satu pilihan yang
diberikan.

Seperti saluran TV, setiap view memperlihatkan informasi yang berbeda.
Tabel-tabel dan filters memperjelas informasi. Seperti juga berpindah dari
saluran yang satu ke yang lainnya, berpindah dari satu view ke yang lain tidak
akan menghapus informasi. Sementara Jiter dapat juga menyembunyikan
informasi, tapi tetap tidak menghapuskannya.

Pada saat kita pertama kali membuka MS Project 2007, maka terdapat tiga

bagian penting yang terlihat yaitu:

1. Padabagian sebelah kiri adalah View Bar (apabila tidak terlihat pilihlah
menu View > View Bar) akan menampilkan ikon-ikon View penting
yang biasa dipergunakan di MS Project 2007.

2. Pada bagian tengah adalah tabel di mana kita bisa memasukkan data-
data yang diperlukan sesuai dengan View yang dipilih.

8 W Panduan Lengkap Mengelola Proyek dengan Microsoft Project Professional 2007

!

Pada bagian kanan adalah tempat kerja (workspace) yang berisi
informasi-informasi grafis (khususnya pada tampilan Ganzt Charz).

‘~; ! Workspace

I

Gambar 1.5 Tumpilan Awal MS Project 2007

1.4 Bagaimana MS Project 2007 Melakukan Penjadwalan

Bagaimana MS Project 2007 menjadwalkan suatu awal dan akhir suatu
kegiatan? Banyak faktor dipertimbangkan, termasuk' kefer.gantung?n
kegiatan-kegiatan, batasan-batasan, dan interupsi SCI?CI‘U har.1 libur. Lebih
penting lagi,"MS Project 2007 menjadwalkan setiap kegiatan dengan

menggunakan formula:

Duration = work / resource effort

*  Duration adalah jumlah waktu sesungguhnya yang diperlukan untuk

menyelesaikan suatu kegiatan. -
*  Work adalah usaha yang diperlukan pada suatu periode waktu untuk

menyelesaikan suatu kegiatan. ' .
*  Resource effort adalah jumlah usaha sumber daya yang dialokasikan

untuk mengerjakan kegiatan tersebut.

Pengenalan Manajemen Proyek 9




Contohnya, jika:

*  Tiga tukang cat bekerja sclama 2 hari untuk suatu kegiatan tertentu,
dengan usaha 8 jam per hari, work untuk setiap sumber daya adalah 16
jam. (2 hari* 8 jam).

*  Total effort dari sumber daya adalah 24 jam per hari (3 tukang* 8

jam).

*  Total work untuk kegiatan tersebut adalah 48 jam: (2 hari * 8 jam* 3
tukang).

*  Duration adalah 2 hari yang didapatkan dari 48 jam/ (3 tukang* 8
jam).

Pengertian akan formula ini sangat penting untuk mengerti bagaimana
perubahan yang Anda lakukan mempengaruhi waktu penyelesaian proyek.
Jadi pada saat kita mendefinisikan suatu kegiatan dan kemudian ditentukan
waktu pelaksanaannya misalnya 2 hari, maka saat itu kita melakukan alokasi
sumber daya manusia di pekerjaan tersebut, dan semakin banyak sumber
daya yang kita alokasikan ke tugas tersebut, maka waktu pelaksanaan tugas
tersebut akan menyusut menurut rumus diatas.

1.5 Menyatukan Semuanya

Setelah Anda menciptakan daftar kegiatan dan menyediakan informasi
jadwal, rencana Anda Dibuat. Anda dapat melihat model keseluruhan
dari proyek Anda, termasuk tanggal penyelesaian dan tanggal mulai untuk
setiap kegiatan. Apa lagi selanjutnya?

*  Review critical paths untuk problem-problem yang mungkin muncul.
Critical path adalah suatu seri dari aktivitas-aktivitas yang berhubungan
yang harus diselesaikan pada waktunya untuk suatu proyek dari awal
sampai akhir. Jika ada kegiatan yang tertunda, ini dapat menyebabkan
penundaan penyelesaian proyek (lihat bab 6).

*  Evaluasi dan optimasi rencana sampai anda puas. Sebelum Anda
memulai proyek Anda dan secara periodik selama proyek berlangsung,
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Anda akan perlu mengevaluasi - dan menyesuaikan  rencana.
Pertimbangkan cakupan, sumber daya dan jadwal (lihat bab 7).

*  Update MS Project 2007 mengenai kemajuan dari kegiatan-kegiatan.
Sebagai gantinya, software ini akan memperlihatkan rencana pro'yek
yang sudah di-update. Setelah rencana di-update, review untuk melihat
efek dari perubahan. Apakah proyek menjadi over budges? Apakah ada
seorang anggota tim yang sekarang harus dijadwalkan untuk lembur?
Apakah proyek Anda akan menjadi terlambat? (lihat bab 7). .

«  Tutup proyek. Evaluasi apa yang sudah diterima dan praktek terbaik
apa yang dapat dilakukan untuk proyek-proyek selanjutnya.

Pada bagian selanjutnya dari buku ini, akan diberikan petunjuk-petunjuk
untuk mempelajari fitur-fitur utama MS Project 2007 beserta petunjuk-
petunjuk agar MS Project 2007 dapat dipergunakan secara optimal pada

saat perencanaan, monitoring (pelacakan) ataupun perubahan proyek.

-00000-
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Bah 2

Mendefinisikan dan Membuat
Suatu Rencana Proyek
(Project Plan)

Di dalam siklus hidup proyek yang dibahas di bab 1, langkah pertama
pelaksanaan proyek adalah mendefinisikan proyek. Pada tahap ini
kegiatan yang dilakukan adalah menentukan proyek mana yang akan
dilakukan, mendapatkan sumber daya yang mencukupi, menentukan
pelaku-pelaku proyek (disebut project stakebolder), dan juga menentukan
waktu pelaksanaan proyek. Setelah semua ini didapatkan (biasanya dapat
dituangkan dalam sebuah dokumen singkat yang disebut Traktat Proyek),
maka tahapan selanjutnya yaitu perencanaan proyek dapat dilaksanakan.

Merencanakan proyek merupakan kegiatan penting yang harus dilak-
sanakan untuk keberhasilan pelaksanaan proyek. Pada tahapan ini sebuah
dokumen Rencana Proyek (Project Plan) dihasilkan. Langkah-langkah
yang bisa dilakukan untuk memulai membuat rencana proyek adalah:

1. Memasukkan dan mengorganisasikan daftar kegiatan-kegiatan untuk
diselesaikan, juga lama penyelesaian setiap kegiatan (duration)

2. Menambahkan sumber daya: orang, perlengkapan, dan materi beserta
biayanya untuk rencana Anda.

3. Menempatkan sumber daya-sumber daya tersebut. untuk kegiatan-
kegiatan yang sesuai.



Dengan informasi itu, M$S Project 2007 akan menciptakan suatu jadwal.

Anda dapat memeriksa dan menyesuaikannya sebagaimana diperlukan.

2.1 Membuat Traktat Proyek

Traktat Proyek (Project Charter) adalah sebuah dokumen singkat yang
menandai dimulainya suatu proyek. Traktat Proyek ini dapat dianggap

sebagai dokumen resmi pertama dari sebuah proyek yang isinya adalah:

*  Nama proyek resmi

*  Sponsor buat proyek dan kontak informasi

*  Manager proyek dan kontak informasi

*  Goal(tujuan) proyek

*  Penjelasan asal-muasal proyek

*  Deliverables (hasil akhir) dari fase-fase dalam proyek

*  Strategi global dalam pelaksanaan proyek

*  Perhitungan waktu kasar

*  Sarana dan prasarana serta sumber daya proyek, biaya (secara kasar),
staff, vendors/stakebolders

Traktat proyek ini sebaiknya ditandatangani oleh semua orang yang terlibat
secara langsung di proyek (disebut Project Stakeholders) dengan tujuan akan
menciptakan rasa tanggung jawab dan kesamaan visi bagi semua pihak
yang terlibat langsung pada proyek.

2.2 Menciptakan Suatu Proyek Baru

Ketika memulai suatu proyek baru didalam MS Project 2007, Anda dapat
memasukkan waktu mulai (st27¢) atau selesai (finish), tapi tidak keduanya.
Direkomendasikanbahwa Anda hanya memasukkanwaktumulai proyekdan
membiarkan MS Project 2007 untuk menghitung waktu penyelesaiannya
setelah Anda memasukkan semua kegiatan dan menjadwalkannya. Jika
proyek Anda harus diselesaikan pada tanggal tertentu, masukkan finish date
saja. Bahkan jika Anda pada mulanya menjadwalkan mulai dari finish date,
lebih baik untuk menjadwalkan dari star¢ date setelah proyek dimulai.
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Langkah-langkah yang dilakukan setelab aplikasi MS Project 2007 dibuka

adalah:

Klik menu File > New, atau tombol shorfcumya.

2. Pilih menu Project > Project Information, pada bagian Schedule from

pilihlah salah satu pilihan:
*  Project Start Date: proyek dijadwalkan dari rencana awal permulaan

proyek. Masukkan rencana tanggal awal proyek pada bagian Szars
date yang sesuai dengan rencana permulaan proyek yang sudah

ditetapkan. . '
*  Project Finish Date: proyek dijadwalkan dari target akhir dari

proyek. Masukkan target tanggal akhir proyek di bagian Finish
date yang sesuai dengan target penyelesaian proyek yang sudah
ditetapkan.

Erishdate: [T 9,3/06 “1 Satusdate: . [NA 7 ~
Schedude from: | Project Start Date “Ej)cw: [Standard : mmM

| N

{ Custom Field Name - T egue

Help . .. | | Statistics... B

Gambar 2.1 Memasukkan Informasi Tentang Proyek

3. Klik File > Save As untuk menyimpan berkas proyek.
4. Di dalam File name box misalnya bernama MyProject, ketik nama
proyek anda, kemudian tekan tombol Save
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Gambar 2.2 Menyimpan Berkas Proyek

Perbedaan antara memasukkan informasi proyek menurut awal proyek atau

akhir proyek adalah:

*  Apabila kita memasukkan informasi proyek berdasarkan awal proyek
(Prject Start Date) maka semua kegiatan akan dihubungkan dengan
tanggal awal tersebut. Kegiatan pertama dari proyek pasti akan
dilaksanakan pada hari pertama proyek tersebut dan kegiatan-kegiatan
yang lain akan menyesuaikan,

*  Apabila kita memasukkan informasi proyek berdasarkan akhir proyek
(Project Finish Date) maka semua kegiatan akan dihubungkan dengan
tanggal akhir terebut. Kegiatan paling akhir dari proyek pasti akan
berakhir pada tanggal akhir proyek tersebut dan kegiatan-kegiatan
lain akan menyesuaikan.

2.3 Mengatur Kalender Proyek

Pada bagian Project Information seperti yang ditunjukkan pada gambar
2.1 terdapat pilihan Calendar yang isiannya adalah Standard. Anda dapat
mengganti kalender proyek sesuai dengan hari kerja dan jam-jam untuk
setiap orang di proyek anda. Kalender dasar yang berlaku adalah Senin ke
Jumat, 8 pagi sampai 5 sore, dengan 1 jam istirahat untuk makan siang.
Anda dapat juga menentukan hari-hari di mana orang tersebut. libur,
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1. Dari menu View, klik Gantt Chart .
2. Dari menu Tools, klik Change Working Time

For calendar: | Standard (Profect Calendar) vl
Calendar ‘Standard is a base colendar. | - :
iy : toseeitsgbvmg&nes: X ; i
T Semec 2009 Al Working tmes for January 9, 2009 . -
TEIe T [wlm[FIs] 800 AME 1ZI00PH .
1 I ERE o 1:00 PM to 5:00 PM
s |7 { 9% :
7T . :
13 [18 |16 . ’
{22 B 2] 1 peraik workwesk on caefider ‘Standard.
EAEAEIEREE . ; W
- LF e
- : Start Foish
T Thame &

Gambar 2.3 Mengganti Kalender Kerja

3. Pilihlah salah satu hari yang memiliki jam kerja khusus. Sel:)agai contcc)lh
pada tanggal 9 Januari 2009 hanya bekerja} setengah hari karena a 2
acara perusahaan. Pada bagian Tab Exceptions ma?ukkan suatu namt
pada baris pertama di bawah Name misalnya Keg.zaz‘an Khusus gtmlah
Setelah diklik pada bagian Szars maka tanggal hari yang sudah dipi 1.[
akan muncul sebagai penanda awal dan akhir. Tekan tombol Details

untuk memberikan detil jam kerja hari tersebut.
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Calendar ‘Standard'is a base calendar.
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Gambar 2.4 Memasukban Informasi Jam Kerja Khusus

Pada bagian Dezails, isilah jam ketja baru yang diinginkan untuk
hari tersebut. Misalnya karena pada hari Jumat tanggal 9 Januari
2009 tersebut jam ketja hanya dari jam 8:00 sampai jam 12:00 dan
tidak ada jam kerja siang. Maka bagian jam 13:00-17:00 dihapus.
Pada tampilan Details, kita juga bisa menambahkan kegiatan yang
sifatnya berulang atau tidak. Apabila sifatnya berulang kita bisa
menambahkan detil pada bagian Recurrence pattern yaitu:
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Set working times for thess exceptions -~ -~~~

O Norworking
(©) Working times:

HRYSm Yo
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Gambar 2.5 Memasukkan Detil Hari Kerja Khusus

- Daily: pengecualian ini berlaku secara harian dengan memilih
akan berulang setiap berapa hari sekali.

- Weekly: pengecualian ini berlaku secara mingguan dengan
memilih akan berulang berapa minggu sekali. Hari-hari
dimana pengecualian berlaku juga bisa ditentukan.

- Monthly: pengecualian ini berlaku secara bulanan yang bisa
dipilih berulang pada tanggal tertentu setiap bulan ataukah
terjadi setiap minggu keberapa dari bulan yang diinginkan.

- Yearly: pengecualian ini berlaku secara tahunan yang bisa
dipilih berulang pada tanggal tertentu setiap tahun atau
berulang pada hari tertentu pada bulan tertentu pada tahun
yang diinginkan.

Pada bagian Range of recurrence, kita perlu menentukan sampai

kapan pengecualian ini akan berakhir atau memilih setelah
berlangsung berapa kali.
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Sebagai contoh kegiatan tahunan, misalnya pada tanggal 26 Juni
merupakan hari libur perusahaan yang artinya merupakan hari
libur khusus untuk hari itu, caranya sama yaitu mengklik tanggal
yang diinginkan. Tambahkan Exceptions baru yaitu Libur ulang
tahun perusabaan

For calendar:
Calendar Standord is & base calendar, ) . o : : ;
o Gickon a day to seeiks orking ines: '+ - s
June 2008 1 U - :;,] e 25, 2009 is nonworking,
sImlvIwlmw[rls] B
T2l e s (5] |
EREN N CREE PR ER \}
Eu

W15 [16 |17 [18 18 |20.]—

S R

o

Gambar 2.6 Memasubban Hari Libur Khusus

Pada bagian Details, pada radio button dipilih Nonworking times
untuk menandakan bahwa hari itu tidak merupakan hari kerja.
Masukkan Recurrence pattern sebagai tahunan atau Yearly dan
terjadi setiap tanggal 26 Juni. Pada bagian Range of recurrence
pilihlah berapa lama kegiatan ini akan berakhir, misalnya selama

15 tahun kedepan. Klik tombol OK.
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Set working times for these axcaptions - - === ‘
y

O Working times:

{ Fri 62609 v[

Gambar 2.7 Memasukkan Hari Libur Khusus

2.4 Membuat Kalender Baru

Kita juga bisa membuat kalender baru yang khusus ditujukan un.tuk peker!'a
tertentu. Misalkan pengawas atau petugas tertentu hanya bisa tersedxa}
pada hari tertentu saja yaitu hari Kamis saja dan tidak tersedia pada hari

Dari menu View, klik Gantt Chart

2. Dari menu Tools, klik Change Working Time .

3. Tekanlah tombol Create New Calendar ... yang terdapat pada .bagmn
kanan atas. Masukkan informasi berupa nama dari kalcnde.r misalnya
Kamis saja dan kemudian pilihlah apakah akan membuat basis ka.lendex.'
yang baru dengan memilih Create new base calendar atau mengkopi
dari kalender yang sebelumnya ada. Piliblah Create new base calendar

untuk membuat basis kalender yang baru.
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For galondar: [sgg?gaq_(pfppuct Calendar)

Calendar ‘Standard' is a base calendar,
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Gambar 2.9 Memberi Nama Basis Kalender yang Baru
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Scbuah tampilan yang mirip dengan gambar 2.8 akan muncul dengan
pada bagian For calendar terpilih Kamis saja yang baru saja dibuat.
Pada bagian tengah pilihlah tengah pilihlah bagian Tab Work Weeks.
Pilihlah [Default] pada table dan tekan tombol Dezails di sebelah

kanan.

For alendar:

Calendar 'Kamis saje’ is a base calendar,

Kanis saja v

Click on a'day to see its working times:

; September 2008 Ali Working times for September 9, .2008:
SIMIT W Th £ S + 800 AM to 12:00 PM

' EEE + 1:00 PM to 5:00 PM

718 W 12 |15

1415 {16 |17 |18 |19 |20
i | Based on:

22|22 25128120 | oo workweekon caendar Xamis
26.[29 [30 s s

Gambar 2.10 Memodifikasi Basis Kalender yang Baru

5. Tentukanlah detil jam kerja pada setiap hari yang ditunjukkan pada
tampilan berikutnya. Misalnya untuk hari minggu, senin, selasa, rabu,
jumat dan sabtu pilihlah Set days to nonworking time untuk menandakan
hari tersebut bukan merupakan hari kerja.
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Set working time for this work week - = - +--m e

Select day(s):

ISunday )

Monday -

: }Tuesday
Wednesday

1 Thursday
Friday

| Saturday

O Use Project defautt times For thesa days.

Gambar 2.11 Menentukan Suatu Hari Menjadi Bukan Hari Kerja

6. Sedangkan untuk hari kamis, pilihlah Ses day(s) to these specific working
times dan tentukanlah jam kerja untuk hari tersebut. Setelah ditentukan,

tekanlah tombol OK dan kemudjan pada tampilan di gambar 2.10
tekanlah juga tombol OK.

Set working time For

Gambar 2.12 Menentukan Hari Kerja Spesifik Suatu Hari
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M 1 > . . - oS - > cr
7. Kita juga bisa menambahkan hari-hari khusus pada basis kalend

yang baru ini scperti yang sudah dicontohkan pada bagian 2.3.
Sctelah proses membuat proyek yang baru dan membuat basis kalf:nder dan
hal-hal lainnya yang dibahas pada bab ini, sekarang kita sudah siap u.ntuk
melangkah ke bagian selanjutnya yaitu memasukkan kegiatan-kegiatan

yang merupakan bagian dari proyek di ke dalam MS Project 2007.
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Bah 3

Memasukkan dan
Mengorganisasikan Kegiatan
dalam Sebuah Proyek

etelah semua persiapan mengenai proyek dan kalendernya sudah dilakukan

di bab 2, maka langkah selanjutnya adalah menyusun rencana proyek
secara lengkap. Langkap pertama yang perlu dilakukan adalah membuat daftar
langkah-langkah yang dibutuhkan untuk mencapai tujuan dari proyek anda,
secara manual. Pendekatan yang dapat dilakukan adalah sebagai berikut:

*  Pendekatan Atas - Bawah (7op Down): kita menentukan dulu tahapan-
tahapan besar yang perlu dilakukan pada saat pelaksanaan proyek.
Sebagai acuannya adalah siklus hidup proyek yang sudah digambarkan
di bab 1. Setelah itu baru menentukan tugas-tugas kecil yang menjadi
bagian dari tahapan-tahapan besar tersebut.

*  Pendekatan Bawah - Atas (Botfom Up): prinsipnya terbalik dari yang
sebelumnya dimana kita menentukan dulu kegiatan-kegiatan kecil
yang perlu dilakukan, kemudian menggabungkan kegiatan-kegiatan
tersebut menjadi tahapan-tahapan besar.

¢ Kombinasi keduanya: kombinasi dari pendekatan Atas - Bawah
digabungkan dengan pendekatan Bawah - Atas untuk memastikan
tidak ada kegiatan atau tahapan yang terlewatkan.



Jangan lupa juga untuk menambahkan milestones (penanda pencapaian)
sebagai kegiatan terakhir yang menandakan akhir dari suatu tahapan
dan kesiapan untuk melakukan tabapan selanjutnya. Kemudian akhirnya,
cari dan masukkan estimasi lama waktu penyelesaian. Setelah informasi
kegiatan didapat, kemudian dimasukkan dalam MS Project 2007, ciptakan
suatu kerangka/outline untuk membantu anda melihat struktur proyek.
Untuk studi kasus kita kali ini akan mengambil kasus pembangunan suatu
rumah dengan pendekatan Bawah - Atas.

3.1 Masukkan Kegiatan-kegiatan dan Lama Waktunya

Tabel 3.1 Dattar Kegiatan Proyck Pembangunan Rumah

Sebuah proyek pada umumnya adalah suatu rangkaian kegiatan yang
berhubungan satu sama lain. Suatu kegiatan menyajikan banyaknya kerja
dengan suatu hasil tertentu (deliverable). Kegiatan-kegiatan sebaiknya
dipecah dalam lama waktu antara 1 hari sampai 2 minggu, untuk
mempermudah monitor kemajuan yang telah dijalani.

Masukkan kegiatan di dalam urutan kapan mereka akan dikerjakan.
Kemudian estimasikan berapa lama waktu yang dibutuhkan untuk
menyelesaikan setiap kegiatan, dan masukkan estimasi lamanya tersebut.
di dalam duration. MS Project 2007 menggunakan duration ini untuk

menghitung berapa banyak kerja yang perlu dilakukan untuk satu
kegiatan.

Catatan: Jangan masukkan tanggal di dalam Stars dan Finish freld karena
MS Project 2007 menghitung tanggal stzr¢ dan Jinish berdasarkan durasi

yang dimasukkan dan juga hubungannya antara satu kegiatan dengan yang
lainnya.

Sebagai studi kasus, perhatikan kegiatan-kegiatan yang dilakukan saat
membangun sebuah rumah. Perincian langkah-langkah membangun
rumah beserta perkiraan lama waktu yang diperlukan untuk melakukan
setiap kegiatan adalah tertera pada Tabel 3.1.
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Nama Tugas (Taks Name) Lama Pengerjaan (Duration)
Pengukuran Tanah 1 hari
Pembuatan Patok Penggalian 1 hari
Penggalian Pondasi 3 hari
Pengurukan Pasir 1 hari
Penyusunan Pondasi S hari
Pengeringan Pondasi 1 hari
Pengaturan Pengecoran Otot 1 hari
Pengecoran Otot Pondasi 2 hari
Pengeringan Otot Pondasi 1 hari
Penyusunan Tembok Bata 2 minggu
Pemasangan Kusen 3 hari
Pemasangan Pipa Listrik 2 hari
Pemasangan Kuda - Kuda Atap 1 minggu
Pemasangan Kayu Usuk 1 minggu
Pemasangan Kayu Reng 2 minggu
Pemasangan Genting 1 minggu

Plester Tembok 2 minggu
Pengecatan Tembok 1 minggu
Pemasangan Listrik 3 hari
Pemasangan Lantai Keramik 1 minggu
Pemasangan WC / Kamar Mandi 4 hari
Pemasangan Dapur 4 hari
Pemasangan Jalur PDAM 2 hari
Pengerjaan Pagar 5 hari
Pengerjaan Taman 2 hari

Catatan: dengan asumsi lima hari kerja, maka pekerjaan selama 1 minggu berarti

5 hari.
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Sctelah kita membukan MS Project 2007, lakukanlah Langkah Tangkah
sebagai berikut:

1.
2.

Dari menu View, klik Gantt Chars

Di dalam field 7ask Name, masukkan nama Kegiatan-kegiatan diatas
beserta lama pengerjaannya.

Di dalam field Duration, masukkan lama waktu untuk setiap kegiatan
beserta singkatan satuan waktu durasi. Singkatan-singkatan berikut
ini dapat digunakan saat memasukkan durasi:

Bulan = months = mo

Minggu = weeks = w

Hari = days = d

Jam = hours = h

Menit = minutes = m

o 0 Top

Tekan Enter,ulangilah sampai seluruh kegiatan yang tertera pada tabel
3.1 semuanya sudah dimasukkan ke dalam MS Project 2007. Tampilan

dari MS Project setelah semua kegiatan diatas sudah dimasukkan
adalah sebagai berikut:

Mon 171209 |

on 111908 |
" Mon 17208 |
Wed 1,708 |
o 14208 |
| Tidmos |
T
“Tos 600 |
Mon 114208

T inod |

L,

P i

N

Gambar 3.1 Tampilan Setelah Kegiatan dan Durasinya Dimasubkan
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Catatan:

Sccara default waktu adalah I day? Yang berarti perkiraan waktu
1 hari. Dan ini dapat diubah sesuai rencana kerja yang telah
dibuat.

Tanda tanya dibelakang menunjukkan ini adalah waktu yang
diperkirakan. Bila anda yakin akan durasi suatu aktivitas maka tanda
tanya ini dapat dibuang. . .
Anda juga dapat menulis suatu catatan mengenai suatu kegla}tan.
Di dalam field Tusk Name, klik kanan kegiatan yang akan dlberlkz%n
catatan, kemudian pilihlah Zask Nofes. Ketik catatan anda, dan klik

OK.

ok rfa rmat

General ] Predecessors l Resources advanced Notes | Custom Fields

e Bk
Name: |Pengaturan Pengecoran

1. Pengecoren harus cilaksanakan segera
2. Pengecoran harus disaksikan oleh pemitk rumah dan developer

) Coc J [ ]

Gambar 3.2 Memberikan Cataran untuk Suatu Kegiatan
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3.2 Menciptakan Milestone (Penanda Pencapaian)

Sebuah milestoneadalah kegiatanyang anda gunakan untuk mengidentifikasi
suatu kejadian yang signifikan di dalam suatu fase dari proyek, seperti
penyelesaian suatu tahapan - tahapan penting. Ketika anda memasukkan
suatu kegiatan dan menuliskan lama waktunya adalah 0 days, itu dijadikan
sebagai milestone. Ada simbol berbentuk wajik hitam pada Gantt Chars
yang menandai bahwa itu adalah suatu milestone.

Sebagai contoh, untuk proyek pembangunan rumah sebagai studi kasus,
diketahui bahwa milestones-nya adalah sebagai berikut:

Tabel 3.2 Daftar Milestones Proyek

Nama Milestone Keterangan
Pemeriksaan Patok Pengukuran Dilakukan setelah kegiatan
pembuatan patok penggalian
Pemeriksaan Pondasi Dilakukan setelah kegiatan
pengeringan pondasi
Pemeriksaan Tembok Dilakukan setelah kegiatan
pemasangan pipa listrik
Pemeriksaan Atap Dilakukan setelah kegiatan
pemasangan genting
Pemeriksaan Interior Dilakukan setelah kegiatan
pemasangan dapur
Penyerahan ke Pemilik Dilakukan pada tahapan paling akhir
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Untuk menasukkan mifestones diatas, takukanlah langkah-langkah berikut

pada berkas proyek pembangunan rumah:

1.

Klik di kolom paling kanan dimana terdapat nomor dimana milestone
akan dimasukkan, klik kanan dan pilihlah New Task. Semua kegiatan
mulai dari 7ask yang dipilih akan turun satu tingkat untuk memberikan
tempat bagi tugas baru. Tuliskan milestone yang ingin dimasukkax}.‘

Setelah menuliskan nama kegiatan, di dalam duration, ketik atau pilih
0 days. Pada tampilan Gantt Chart akan muncul wajik hitam sebagai

penanda milestone.

Tekan Enter
Ulangi sampai semua milestones telah dimasukkan semuanya.

Pada gambar berikut diperlihatkan keempat milestone telah dimasukkan ke
dalam daftar kegiatan.

Gambar 3.3 Berkas Proyek Setelah Milestones Dimasukkan Semuanya
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Catatan:

tidak berdurasi 0 menjadi milestone.

* Misalnya untuk kegiatan Pemeriksaan Interior sebenarnya
membutuhkan waktu 1 hari namun kita ingin menjadikannya sebuah
milestone. Caranya dengan mengklik kanan kegiatan tersebut dan
memilih Zusk Information. Setelah muncul tampilan Task Information
pilihlah 72 Advanced dan berikan tanda cek disamping Mark tash a.v,

milestone. Setelah itu tekan tombol OK.

Gambar 3.4 Menandai Kegiatan Bukan Berdurasi 0 Menjadi Sebuak
Milestone

3.3 Membuat Recurring Task atau Kegiatan yang Dilakukan
Berulang

Selain dengan membuat suatu kegiatan menjadi sebuah milestone
dengan memasukkan durasi 0, dapat juga kegiatan-kegiatan yang

Recurring tasks adalah kegiatan-kegiatan yang berulang secara reguler,
misalnya pertemuan mingguan, review, audit periodik dan lain - lain.
Recurring task dapat juga dilakukan secara harian, mingguan, bulanan, atau
bahkan tahunan. Anda dapat menentukan lama setiap kegiatan tersebut
dilaksanakan, kapan dilaksanakannya, dan seberapa lama, maupun berapa
kali kegiatan tersebut harus dilaksanakan.
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Misalnya namactugas adalah: Pengecekan Rutin yang dilakukan setiap minggu
yvang dilaksanakan setiap hari Rabu. Untuk memasukkan tugas berulang ini
ke dalam proyck pembangunan rumah adalah sebagai berikut:

1. Didalam field 7ask Name, klik baris di mana anda ingin recurring task

muncul, misalnya pada bagian teratas.

Di dalam menu Insers, klik Recurring Task

Di dalam 7ask Name box, ketik nama kegiatan tsb yaitu Pengecekan Rutin.

Di dalam Duration box, ketik atau pilih durasi dari satu kali kegiatan

tersebut berlangsung, yaitu 1d atau 1 hari saja.

5. Pilih pola pengulangan atau recurrence pattern, dapat dipilih misalnya
Daily untuk harian, Weekly untuk mingguan, Monzhly untuk bulanan,
dan Yearly untuk tahunan. Untuk kegiatan Pengecekan Rutin ini
dilakukan mingguan setiap hari Rabu.

6. Di dalam Range of recurrence, ketik tanggal mulai atau start di dalam
kotak Szart dan kemudian pilih End after atau End by
a. Jika End after yang dipilih, ketik jumlah berapa kali kegiatan ingin

dilakukan.
b. Jika End by yang dipilih, ketik tanggal kapan anda ingin recurring
task tersebut berakhir.
Untuk kegiatan Pengecekan Rutin akan berakhir di akhir bulan Maret
2009 (akan disesuaikan nanti).

o

General ' Predecessor's ] Resources Advanced l Notes
Name: - [Pemeriksaan Intarior | puretion: 14
OIS BIRASI o o o b S e o e oo it W e s
Deadive: > M
Constraint type: . | As Soon As Possible ]
Concel .

Gambar 3.5 Mengisikan Informasi Tentang Recurrence Task
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3.4 Menyusun Struktur Kegiatan-kegiatan Menjadi Kerangka

Logis

Setelah kita menckan tombol OK, maka kegiatan Pengecekan Rutin akan
muncul beserta ikon 2 buah panah melingkar. Untuk masing - masing

kegiatannya dapat dilihat dengan mengklik tanda + di depan nama kegiatan

tersebut. Dengan menggunakan outline, anda akan dapat menyusun suatu hirarki

kegiatan, sehingga akan lebih mudah mengaturnya. Untuk hal itu, dapat
digunakan tombol-tombol out/ine (bila tidak aktif, dapat diaktifkan dari:
View > Toolbars > Formatting). Tombol tombol ini adalah yang berupa
panah ke kanan (indent), panah ke kiri (outdent), tanda plus (show subtasks),
dan tanda minus (bide subtasks).

ish

Gambar 2.5 Formatting Toolbars

Keterangan:
- Panah ke kiri (owtdens): menjadikan suatu kegiatan/task menjadi

sebuah tahapan (summary task)

- Panah ke kanan (indens): menjadikan suatu kegiatan/task menjadi
bagian dari summary task diatasnya.

- Tanda + (show subtasks): menunjukkan detil task-task yang menjadi
bagian dari suatu Summary Task (apabila dalam kondisi tersembunyi)

- Tanda - (hide subtasks): menyembunyikan detil task - task yang menjadi
bagian dari suatu Summary Task (apabila dalam kondisi terlihat)

Gambar 2.4 Recurring Task Telah Dimasubkan dalam Proyek

Catatan:

*  Kegiatan berulang atau recurring task yang kita masukkan diatas masih
bersifat statis. Artinya tidak fleksibel mengikuti kegiatan lainnya,

*  Untuk membuat suatu kegiatan berulang (recurring task) menijadi
fieksibel, yang perlu dilakukan adalah menghubungkan antara kegiatan
pertama dan terakhir dari kegiatan berulang tersebut dengan hubungan
FF (F inish-to-Finish). Kelemahan dari teknik ini adalah apabila durasi
kegiatan berubah, jumlah kegiatan berulangnya tidak akan bertambah
atau berkurang. Lihat bab 4 untuk melihat cara menghubungkan dua
buah kegiatan secara FF.

Seluruh kegiatan-kegiatan yang sudah disebutkan diatas, kalau kita
perhatikan sebenarnya dibagi dalam fase-fase kegiatan yang dalam MS
Project 2007 dinamakan tahapan atau Swmmary Task. Suatu summary
task terdiri dari beberapa kegiatan (#2s%) dan biasanya diakhiri oleh suatu
milestone sebagai tanda berakhirnya tahapan tersebut dan siap untuk masuk

ke tahapan berikutnya.
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Rangkaian kegiatan yang menjadi contoh disini (pembuatan rumah) dapat

Kode WBS Nama Tugas (1uks Name) Lama Pengetjaan
n
diklasifikasikan menjadi 6 tahapan atau summary task, yaitu: (WRBS Code) (Duratio
L Penyiap an Lahan 3.1 Pengaturan Pengecoran Otot 1 hari
2. Pembangunan Pondasi 3.2 Pengecoran Otot Pondasi 2 hari
3. Penyusunan Tembok = ) 1 hari
4. Penyusunan Atap 3.3 Pengeringan Otot Pondasi ari
5. Pengerjaan Interior 3.4 Penyusunan Tembok Bata 2 minggu
6. Pengerjaan Interior 35 Pemasangan Kusen 3 hari
3.6 Pemasangan Pipa Listrik 2 hari
Apabila seluruh kegiatan proyek pembuatan rumah secara lengkap dengan i T i
i 0
mengikut sertakan summary task, task, dan milestone lengkap dengan 3.7 Pemeriksaan Tem
durasi pengerjaannya adalah sebagai berikut: 4 Penyusunan Atap
41 Pemasangan Kuda - Kuda Atap 1 minggu
Tabel 3.3 Daftar Kegiatan Proyek Pengerjaan Rumah Secara Lengkap . Pemasangan Kayu Usuk 1 minggu
4.3 Pemasangan Kayu Reng 2 minggu
Kode WBS Nama Tugas (Taks Name) Lama Pengerjaan . - 1 mi
(WBS Code) (Duration) 44 Pemasangan Genting minggu
1 Penyiapan Lahan 45 Pemeriksaan Atap Milestone
1.1 Pengukuran Tanah 1 hari 5 Pengerjaan Interior
1.2 Pembuatan Patok Penggalian 1 hari 51 Plester Tembok 2 minggu
1.3 Pemeriksaan Patok Pengukur Milestone 592 Pengecatan Tembok 1 minggu
2 Pembangunan Pondasi 53 Pemasangan Listrik 3 hari
2.1 Penggalian Pondasi 3 hari 54 Pemasangan Lantai Keramik 1 minggu
2.2 Pengurukan Pasir 1 hari 55 Pemasangan WC / Kamar Mandi | 4 hari
bari
23 Penyusunan Pondasi 5 hari 56 Pemasangan Dapur 4 hari '
2.4 Pengeringan Pondasi 1 hari 5.7 Pemeriksaan Interior Milestone (1 hari)
2.5 Pemeriksaan Pondasi Milestone 6 Pengerjaan Eksterior
3 Penyusunan Tembok 6.1 Pemasangan Jalur PDAM 2 hari
6.2 Pengerjaan Pagar 5 hari

d ssional 200: Memasukkan dan N[engorgamsamkan Keglatan dalam Sebuah I()ka ] 3 g




;{ut:;g \(’_:VBS Nama Tugas (Taks Name) Lama Pengerjaan
ode) (Duration)
6.3 Pengerjaan Taman 2 hari
7 Penyerahan ke Pemilik Milestone
Catatan:

Pada kolom paling kanan disengaja ditambahkan kolom yang bernama
kode WBS (WBS Code). WBS atau Work Breakdown Structure
adalah struktur rangkaian kegiatan dalam sebuah
ditunjukkan di tabel 3.3.

proyek seperti yang
Cara memasukkan Summary Task dalam MS Project 2007 sama dengan
memasukkan New Task yaitu dengan mengklik baris kegiatan dimana kita
akan memasukkan Summary Task dan pilih New Task. Isikanlah Rangkaian
Kegiatan pertama yaitu Penyiapan Lahan. Untuk memasukkan Tasé-7Tash
dibawahnya merupakan bagian dari Summary Task Penyiapan Lahan
caranya dengan memilih Zask tersebut kemudian mengklik toolbar indens
yang telah dijelaskan sebelumnya. Tombol outdens diperlukan apabila kita
ingin mengembalikan suatu kegiatan seperti semula (bukan bagian dari
Summary Task diatasnya). Ulangi kegiatan diatas sampai semua Summary

Task dimasukkan dan kegiatan-kegiatan yang merupakan bagian dari
Summary Task tersebut telah di-indens.

Setelah keseluruhan Summary Tusk telah dimasukkan dan task- task yang

menjadi bagian darinya telah ditandai maka rangkaian proyek pembangunan
rumah menjadi sebagai berikut:
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Gambar 2.6 Proyek Pembangunan Rumah Lenghap dengan Summary
Task

Catatan:
Pada Gantt Chart, sebuah summary task akan berbentuk garis hitam

tebal dengan bentuk lancip kebawah pada ujung-ujungnya.

*  Sebuah summary task adalah sebuah tahapan suatu proyek yang detil
- detil tugas dari tahapan tersebut dijelaskan di bawahnya.

«  Di MS Project 2007, tingkat indentasi tidak dibatasi. Jadi bisa saja
sebuah tahapan (Swummary task) memiliki beberapa subtask, dimana
subtask tersebut juga memiliki detil pekerjaan lainnya.

Sampai sekarang ini, kegiatan-kegiatan diatas masih belum dirangkaikan
antara satu dengan yang lainnya sebagai suatu kesatuan kegiatan yang
menyusun sebuah proyek. Tahapan selanjutnya adalah merangkai masing-
masing kegiatan dan tahapan menjadi satu kesatuan yang dijelaskan di bab

4,

-000o0-
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Bah4

Menentukan Awal dan Akhir
Kegiatan-kegiatan

etelah Anda menciptakan kegiatan dan juga menyusun outline dari daftar

kegiatan Anda, baru anda perlu untuk menghubungkan bagaimana
suatu kegiatan berhubungan satu sama lain dan pada tanggal spesifik.
Banyak sekali tipe hubungan kegiatan, yang mana disebut ketergantungan
tugas atau fask dependencies. MS Project 2007 secara otomatis menentukan
tanggal szart dan finish untuk kegiatan-kegiatan yang berhubungan satu
sama lain.

Keuntungan dari hubungan kegiatan-kegiatan ini adalah jika satu kegiatan
berubah,kegiatan-kegiatanyang berhubungan akan secara otomatis dijadwal
ulang. Anda dapat menyempurnakan jadwal kegiatan dengan menggunakan
batasan, overlap atau kegiatan yang ditunda, dan memecahkan kegiatan-
kegiatan ketika pekerjaan yang dilakukan dihentikan untuk sementara.

4.1 Menentukan Hubungan Antar Kegiatan

Untuk menciptakan hubungan antar kegiatan, gunakan fask dependencies.
Pertama-tama, pilih kegiatan-kegiatan yang berhubungan, hubungkan, dan




kemudian ganti dan sesuaikan ketergantungan jika diperlukan, Kegiatan
yang waktu start dan JSinish-nya tergantung yang lain merupakan successor,
sementara successor adalah bergantung pada predecessor-nya. Contohnya,
jika anda menghubungkan “Pasang jam dinding” dengan “Cat tembok
kamar tidur”, maka “Pasang jam dinding” adalah successor, sementara “Cat
tembok kamar tidur” adalah predecessor.

Setelah semua kegiatan terhubung, perubahan pada tanggal predecessor akan
mempengaruhi tanggal successor. MS Project 2007 pada dasarnya, secara
default, menciptakan hubungan fnish-to-start (FS) Karena inj mungkin
tidak selalu berlaku di setiap situasi, ketergantungan ini dapat diganti
dengan start-to-start (SS), JSinish-to-finish (FF), atau start-to-finish (SF)
untuk membuat model proyek anda lebih realistis.

Catatan:

* FS =kegiatan “dari” harus selesai sebelum kegiatan “ke”boleh dimulai.
Hubungan ini merupakan hubungan yang secara default diberikan
di MS Project 2007 apabila kita memblok dua buah kegiatan dan
kemudian memilih menu Edi¢ > Link Tasks.

FF = kegiatan “dari” harus selesai sebelum kegiatan “ke” boleh
selesai (dapat pula selesai bersamaan). Kegiatan kedua hanya boleh
diselesaikan apabila kegiatan yang pertama sudah selesai.

*  SS = kegiatan “dari”harus dimulai sebelum kegiatan “ke”boleh dimulai
(boleh mulai bersamaan). Kegiatan kedua hanya boleh dimulai apabila
kegiatan pertama dimulai.
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SI* kegiatan “dari” harus dimulai sebelum kegiatan “ke”boleh sclesai,

| i i i “dari” h iatan
dengan kata lain mulainya kegiatan “dari” harus menunggu keg'

“ke” sclesai. Kegiatan kedua hanya boleh selesai apabila kegiatan

pertama sudah dimulai.

Langkah- langkah yang harus dilakukan untuk menghubungkan Kegiatan-
kegiatan dalam berkas MS Project adalah sebagai berikut:

1. Pada menu View, klik Gantt Chart .

2. Di dalam field 7Zask Name, pilih 2 atau lebih kegiatan untuk
dihubungkan. . .

3. Pada menu Edit, Klik Link Task (atau klik toolbar berbentuk seperti
rantai)

Gambar 4.1 Tvolbar Untuk Menghubungkan dan Memutus Hubungan Kegiatan

4. Untuk mengganti hubungan antara kegiatan, klik dobel pada garis
penghubung antara kegiatan-kegiatan yang ingin diganti.

Catatan:

Untuk menghilangkan link antara kegiatan, pilih keg.iata‘n.—kegiat‘an
yang ingin diputus hubungannya, dan dari menu Edit, pilih Unlink
Task. . .

Untuk menghubungkan beberapa kegiatan sekaligus secara FS (finish-
fo-star?), bisa dilakukan dengan mengklik task - task ter-se.but secara
bersamaan dan kemudian memilih Ediz > Link Task. Ini juga dapat

dilakukan untuk task - task yang tidak berurutan dengan cara menekan

tombol CTRL pada saat memilih task - task tersebut.

oy

»
R |
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Cara lain adalah dengan mengklik dobel task tersebut dan pada Tab

Predecessor kita memilih tugas pendahulunya dan juga hubungannya

(FS atau yang lain). Ini juga dilakukan apabila terdapat tugas yang
memiliki lebih dari satu pendahulu.

1 - {Pemerksaan - G el 4 :
L | Finishio-Rart (FS, B N ‘
--fmmgié-‘)i - e
22 Pembuatan Patok Yl ""“'-m-;«- (a]:

Gambar 4.2 Memasukkan Predecessors Suatu Kegiatan

Untuk proyek pembuatan rumah sebagai studi kasus, catatan tugas - tugas
yang menjadi pendahulu (predecessor) adalah sebagai berikut:

Tabel 4.1 Kegiatan Proyek Pembangunan Rumah Beserta Pendahulunya

Nama Tugas (Taks Name) Tugas Pendahulu
Penyiapan Lahan -
Pengukuran Tanah -
Pembuatan Patok Penggalian Pengukuran Tanah

Pemeriksaan Patok Pengukur

Pembuatan Patok Penggalian

Pembangunan Pondasi -
Penggalian Pondasi Pemeriksaan Patok Pengukur
Pengurukan Pasir Penggalian Pondasi
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Nama Tugas (Zaks Name)

Tugas Pendahulu

Penyusunan Pondasi

Pengurukan Pasir

Pengeringan Pondasi

Penyusunan Pondasi

Pemeriksaan Pondasi

Pengeringan Pondasi

Penyusunan Tembok

Pengaturan Pengecoran Otot

Pemeriksaan Pondasi

Pengecoran Otot Pondasi

Pengaturan Pengecoran Otot

Pengeringan Otot Pondasi

Pengecoran Otot Pondasi

Penyusunan Tembok Bata Pengeringan Otot Pondasi

Pemasangan Kusen Pengeringan Otot Pondasi

Pemasangan Pipa Listrik Penyusunan Tembok Bata

Pemeriksaan Tembok Penyusunan Tembok Bata
Pemasangan Kusen
Pemasangan Pipa Listrik

Penyusunan Atap -
Pemasangan Kuda - Kuda Atap | Pemeriksaan Tembok

Pemasangan Kayu Usuk Pemasangan Kuda - Kuda Atap
Pemasangan Kayu Reng Pemasangan Kayu Usuk
Pemasangan Genting Pemasangan Kayu Reng

Pemeriksaan Atap Pemasangan Genting
Pengerjaan Interior

Plester Tembok Pemeriksaan Tembok

Pengecatan Tembok Plester Tembok

Pemasangan Listrik Pengecatan Tembok

Pemasangan Lantai Keramik Pengecatan Tembok
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Nama Tugas (Tuks Name) Tugas Pendahulu
Pemasangan WC / Kamar Mandi | Plester Tembok
Pemasangan Dapur Plester Tembok

Pemeriksaan Interior

Pemasangan Listrik

Pemasangan Lantai Keramik

Pemasangan WC/ Kamar Mandi

Pemasangan Dapur

Pengerjaan Eksterior -
Pemasangan Jalur PDAM Pemeriksaan Tembok
Pengerjaan Pagar Pemasangan Jalur PDAM
Pengerjaan Taman Pengerjaan Pagar
Penyerahan ke Pemilik Penyusunan Atap,
Pengerjaan Interior,
Pengerjaan Eksterior
Catatan:

*  Kalau kita perhatikan, tidak semua pekerjaan akan berhubungan satu
dengan yang lain secara serangkai, namun ada beberapa pekerjaan
yang berjalan secara bersamaan atau paralel.

*  Suatu tahapan (Summary Task) boleh dihubungkan dengan tahapan
yang lainnya apabila diperlukan, namun biasanya malah akan
menambah keruwetan di Gantt Charz. Kecuali pada tahapan terakhir
yaitu Penyerahan ke Pemilik harus dihubungkan untuk memperjelas
hubungan keduanya.

* Suatu tahapan (Summary Tusk) sebaiknya dihubungkan dengan
Summary Task juga.

48 ® Panduan Lengkap Mengelola Proyek dengan Microsoft Project Professional 2007

*  Suatu kegiatan scbagai successor bisa dihubungkan dengan lebih dari
satu kegiatan predecessor (lihat kegiatan Pemeriksaan Interior yang
memiliki pendahulu empat buah kegiatan sebelumnya).

Setelah kita menghubungkan masing - masing task - task tersebut maka
tampilan proyek pembangunan rumah adalah sebagai berikut:
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Gambar 4.3 Tampilan Proyek Setelah Kegiatan-kegiatan Dibubungkan

Catatan: . .
*  Terdapat cara cepat untuk menghubungkan Kegiatan-kegiatan dalam

proyek, apabila kita lebarkan bagian tabel pada MS Project 2907 r.naka
kita akan melihat kolom Predecessors, masukkan nomor dari kegiatan
pendahulu pada kolom ini, maka secara otomatis kedua kegiatan akan
dihubungkan secara Finish-to-Start (FS).

*  Untuk suatu kegiatan yang pendahulunya lebih dari satu, dapat
dimasukkan dengan dipisahkan dengan koma. Apabila koma tidak
berhasil (yang dikarenakan karena seting lokal dari komputer), dapat
dicoba dengan titik koma.
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* Apabila ingin menghubungkan  dua kegiatan sclain secara IS
(Finish-to-Stars) dapat dilakukan dengan  menuliskan  nomor
kegiatan pendahulu yang langsung diikuti singkatan dari hubungan
yang diinginkan (FS: Finish-to-Start, SS: Start-to-Start, FF: Finish-
to-Finish, atau SF: Start-to-Finish). Contohnya misalnya 12SS
yang artinya kegiatan pendahulu adalah kegiatan nomor 12 dengan
hubungan SS (Starz-to-Star?).

*  Suatu kegiatan bahkan bisa dihubungkan dengan kegiatan lain di
berkas MS Project yang lain yang disebut exzernal dependency. Hal ini
akan dibahas di bab 8.

4.2 Membuat Kegiatan yang Overlap atau Menambahkan Lag
Time (Waktu Tunggu) di Antara Kegiatan-Kegiatan

Dengan MS Project, anda dapat membuat kegiatan-kegiatan overlap satu
sama lain dengan memasukkan lag time (waktu penundaan) atau lead time
(waktu percepatan). Lag dan lead time dapat juga dimasukkan dalam bentuk
persentase. '

1. Di dalam field Ziask Name, klik kegiatan yang ingin ditambahkan lead
atau lag timenya, kemudian, pilih Zisk information.

2. Klik Predecessor tab

3. Di dalam kolom Lag, ketik berapa lama waktu penundaan yang
diinginkan, sebagai durasi waktu, atau sebagai persentase dari
predecessornya.
a. Ketik lead time sebagai angka negatif (misalnya -2d untuk Jead

time 2 hari) atau sebagai persentase.

b.  Ketik /ag rime sebagai angka positif

4. Klik OK.

Untuk studi kasus pembangunan rumah kita, diketahui bahwa kegiatan
Pemasangan Kusen dilakukan setelah kegiatan Pengeringan Otot Pondasi.
Misalnya kita akan menunggu selama 5 hari setelah Pengeringan Otot Pondasi
sebelaiv: Pemasangan Kusen (misalnya meraberi kesempatan pembangunan
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Tembok untuk dapat dimulai dahulu). Caranya dengan menambahkan Lag

schanyak 5d pada Zask Informasion di Tab Predecessors.

tieme: {Pomasangen fizeen , ] waton: [ 5] [Tesmated
—
7 Pengeringan Otot Pondasi

Gambar 4.4 Memasukkan Lag atau Lead Time pada Task Information

Catatan:

*  Untuk memasukkan /ead dan lag #ime dengan cepat, dapat juga
dimasukkan langsung dengan double-click pada garis penghubung pada
gantt chart.

*  Seperti yang digambarkan pada catatan di gambar 4.3, kita juga
dapat menambahkan Jag atau /ead time secara langsung pada kolom
Predecessors dengan menuliskan nomor kegiatan pendahulu dan
hubungannya terus ditambahkan dengan tanda plus dan lama /ag atau
lead time yang diinginkan. Contohnya pada kolom Predecessors apabila
tertulis 72FS+5d artinya kegiatan pendahulu adalah kegiatan nomor
12 dengan 5 hari /ag time.

4.3 Mengatur Tanggal Start dan Finish yang Spesifik Untuk
Suatu Kegiatan

Kita dapat menjadwalkan kegiatan-kegiatan dengan lebih efektif dengan
menciptakan ketergantungan antar kegiatan, dan membiarkan MS Project 2007
menghitungnya untuk anda. Akan tetapi, anda juga dapat menentukan sendiri
kapan anda ingin kegiatan-kegiatan dimulai atau diakhiri bilamana perlu.
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Batasan kegiatan yang membuat ketergantungan kegiatan terhadap suatu
tanggal yang spesifik disebut inflexible constraints. Yang paling tidak fleksibel
adalah yang mana tanggal starz atau Jinish-nya kita tentukan. Karena MS
Project memperhitungkan hal ini di dalam menghitung waktu penyelesaian
proyek, gunakan batasan ini jika ada keterbatasan waktu penyelesaian.

1. Di dalam field 7ask Name, klik kegiatan yang ingin diset tanggal start

dan finish-nya, kemudian klik 7usk Information dari menu Project
2. Klik Advanced tab

Di dalam box Constrains Type, klik tipe batasan.

4. Ketik atau pilih tanggal di dalam constraint date box, kemudian klik
OK.

»

Misalnya kegiatan Pemasangan Jalur PDAM harus dilakukan pda tanggal
20 Februari 2009 karena sudah membuat janji dengan pihak PDAM.

Kita bisa memasukkan tanggal tersebut dalam bagian Task Information di
Advanced seperti berikut ini.

Constrain task ety

Gambar 4.5 Memasubkan Deadline Berupa Tanggal pada Suatu
Kegiatan

52 & Panduan Lengkap Mengelol: Proyek dengan Microsoft Project Professional 2007

Catatan:

Tipe contraints waktu dalam MS Project 2007:

- As Soon As Possible (ASAP) - default bila memasukkan aktivitas
dengan “start date”: memulai suatu pekerjaan secepat mungkin.

- As Late As Possible (ALAP) - default bila memasukkan aktivitas
dengan “end date”: memulai pekerjaan selambat mungkin tanpa
mengurangi waktu kerja keseluruhan.

- Start No Earlier Than (SNET): memulai aktivitas pada atau setelah
tanggal tertentu.

- Start No Later Than (SNLT): memulai aktivitas tidak lebih awal
dari tanggal tanggal tertentu.

- Finish No Earfier Than (FNET). menyelesaikan suatu aktivitas
pada atau setelah tanggal tertentu.

- Finish No Later Than (FNLT): menyelesaikan suatu aktivitas pada
atau sebelum tanggal tertentu.

- Must Start On (MSO): harus memulai aktivitas pada tanggal
tertentu.

- Must Finish On (MFO): harus menyelesaikan aktivitas pada
tanggal tertentu.

Jika anda memilih tanggal tertentu di dalam stars freld, berarti MS

Project 2007 akan menentukan batasan Start No Earlier Than (SNET)

atau mulai tidak lebih terlambat dari... Jika anda menetapkan finish

date , MS Project secara otomatis menentukan Finish No Earlier Than

(FNET) atau berakhir tidak lebih awal dari ...

Setelah informasi kita masukkan maka pada kegiatan Pemasangan Jalur
PDAM terdapat ikon khusus yang menandakan kegiatan ini memiliki
waktu start yang ditentukan secara khusus.
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Gambar 4.6 I#on Khusus Penanda Kegiatan dengan Keterganfungan
Khusus

4.4 Menambah Deadline Suatu Kegiatan

Ketika anda menentukan suatuy deadline untuk suatu kegiatan, MS Project
2007 menunjukkan suatu indikator jika suatu kegiatan dijadwalkan untuk
selesai setelah deadline. Menentukan suatu deadline tidak mempengaruhi
bagaimana kegiatan-kegiatan dijadwalkan. Ini hanya cara MS Project 2007
untuk menginformasikan jika suatu kegiatan diselesaikan setelah deadline.
Kemudian anda mempunyai kesempatan untuk melakukan penyesuaian
agar jadwal dapat mencapai deadline yang ditentukan.

1. Didalam menu View, pilih Gantr Chars.

2. Didalam field Zisk Name, klik kegiatan yang ingin diset deadlinenya,

3. Kiik Zask Information dan Advanced Tab,

4. Di dalam Constraint Task, ketik atau pilih tanggal deadline di dalam
deadline box, kemudian klik QK.

Misalnya disepakati bahwa kegiatan Penyerahan ke Pemilik akan dilakukan
pada tanggal 10 Maret 2009. In; dapat dilakukan pada bagian 7ask
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Information di Advanced dengan memasukkan tanggal deadline yang
diinginkan.

Nome: [n-y’vdmhm&‘ —

Gambar 4.7 Memasukkan Deadline Suatu Kegiatan

4.5 Mengubah Sifat - Sifat Lain dari Kegiatan

Apabila kita perhatikan pada tampilan Task Information padabbag;a;l
Advanced seperti yang ditunjukkan pada gambar 4.6 dzfn gz;mhar 1.. ,
ternyata banyak aspek dari suatu kegiatan yang da&pat kita u a . s;:l:n
menetapkan constraint ataupun deadline seperti yang ditunjukkan

sebelumnya.

i ‘ ilihan yaitu:
Pada bagian Task type, akan terdapat 3 p ) ‘ .
*  Fixed Units: pilihan default yang berarti unit pekerjaan untuk kegiatan

tersebut adalah sama. .
Fixed Duration: tugasnya memiliki rentang waktu atau durasi yang

tetap tidak tergantung kepada jumlah resource yang diberikan kepada

kegiatan tersebut.
*  Fixed Work: bobot pekerjaan dari kegiatan tersebut adalah sama.

Pada bagian Calendar, kita bisa menetapkan basis kalender yang berl:?.llm
untuk kegiatan ini. Kita bisa membiarkan tetap seperti semula atau memilih
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salah satu jenis basis kalender yang sudaly dibuat seperti yang diperlihatkan
pada bagian 2.4 di buku ini. Apabila kita memilih salah satu jenis basis
kalender dan memberikan tanda cek dj depan Scheduling ignores resource
calendar maka basis kalender yang dipilih akan memiliki prioritas lebih

tinggi saat kegiatan tersebut ditugaskan ke resource tertenty yang memiliki
basis kalender yang berbeda.

Untuk WBS Code akan diberikan secara otomatis sesuai yang telah dibahas
pada bagian 3.4 di buku ini.

Earned Value method menentukan bagaimana proyek akan dilihat di tengah
perjalanannya (memasuki masa pelacakan atau #racking seperti yang akan

dibahas di bab 7 buku ini). Pilihannya adalah:

% Complete: analisa earned value berdasarkan prosentase penyelesaian
pekerjaan.

*  Physical % Complete: analisa earned value berdasarkan pada pekerjaan
- pekerjaan yang sudah selesai saja.

Setelah jadwal beserta Kegiatan-kegiatannya telah disusun dengan baik,
tugas selanjutnya yang tidak kalah penting adalah menentukan resource atau

sumber daya yang akan dipergunakan oleh Kegiatan-kegiatan tersebut.

-00000-
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Menentukan Suatu Kegiatan |
pada Sumber Daya yang Dimiliki

ita perlu menentukan sumber daya yang mana akan mengerjakan

Ksuatu kegiatan tertentu ketika anda ingin:

*  Melihat kemajuan pekerjaan yang dilakukan oleh orang maupun
perlengkapan yang ditentukan untuk suatu kegiatan, atau untuk
memonitor materi-materi yang digunakan.

*  Memiliki lebih banyak fleksibilitas di dalam menjadwalkan kegiatan

*  Memonitor sumber daya yang mendapat beban terlalu banyak atau
terlalu sedikit.

*  Mengawasi biaya dari sumber daya '

Jika resource information ini tidak digunakan, MS Project akan menghitung

jadwal hanya dengan berdasarkan duration dan dependencies saja.

Langkah-langkah yang harus dilakukan adalah pertama kali membuat
daftar sumber daya yang akan dipergunakan oleh proyek lengkap dengan
detil sesuai dengan jenis sumber daya tersebut. Kemudian pada setiap
kegiatan yang sudah dibuat sebelumnya akan dialokasikan sumber dajya
yang akan dipakai untuk melaksanakan kegiatan tersebut. Setelah itu
semua terlaksana, maka informasi tentang proyek yang direncanakan sudah



lengkap yang memungkinkan kita untuk mendapatkan informasi biaya
proyek, meratakan sumber daya yang berbeban lebih, dan lain-lain.

5.1 Membuat Daftar Sumber Daya Proyek

Untuk membuat daftar sumber daya, anda dapat menggunakan menu View
> Resource Sheet di dalam MS Project 2007. Sumber daya dapat bervariasi

dari orang, perlengkapan, maupun materi yang dibutuhkan untuk
melaksanakan kegiatan.

1.

Dari menu View, klik Resource Sheet
Dari menu View, klik ke Table, dan klik Entry
Di dalam field Resource Name, ketik nama dari sumber daya beserta
informasi detil lainnya yang berhubungan dengan jenis sumber daya
tersebut.
Untuk memasukkan sumber daya-sumber daya di dalam suatu grup,
ketik nama grup di dalam Group field
Di dalam field Type, sebutkan tipe sumber daya:
a.  Untuk work resource (orang atau perlengkapan), set resource type
menjadi Work
b.  Untuk material resource (yang dikonsumsi sepanjang proyek), set
resource type menjadi Material
c.  Untuk cost resource (resource yang membutuhkan biaya, misalnya
sewa), set resource type menjadi Cosz
Untuk setiap work resource, ketik jumlah unit sumber daya yang tersedia
untuk sumber daya ini di dalam Max uniz Jield, sebagai persentase.
Misalnya, ketik 300% untuk mengindikasikan 3 full-time unit dari
sumber daya tertentu. Masukkan juga std rate (tarif standar) dan ooz
rate (tarif lembur) dari sumber daya tersebut. Work resource juga bisa
memiliki basis kalender khusus apabila diperlukan.
Untuk setiap material resource, ketik di dalam field Material label, unit
pengukuran untuk unit tersebut, misalnya ton.
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Untuk cost resource, tidak terdapat informasi tambahan yang bisa
dimasukkan, sifatnya hanya untuk catatan saja. Khusus cost res?urce
biayanya akan dimasukkan langsung pada Sa:‘lt mf:r.lga_lokamkan
resource ini pada suatu kegiatan. Contoh kongkrit dari jenis resource

ini adalah ongkos sewa mesin, sewa peralatan dan lain-lain.

Tabel 5.1 Daftar Sumber Daya / Resource Proyek

Resource Name Type Max Std. Rate Ovt. Rate
Unit

Arsitek Work 100% | Rp.75000/day | Rp.100000/day
Mandor 1 Work 100% | Rp.65000/day | Rp.85000/day
Mandor 2 Work 100% | Rp. 65000/day | Rp.85000/day
Tukang Bata 1 Work 100% | Rp.50000/day | Rp.75000/day
Tukang Bata 2 Work 100% | Rp.50000/day | Rp.75000/day
Tukang Bata 3 Work 100% | Rp.50000/day | Rp.75000/day
Asisten Tukang 1 Work 100% | Rp. 45000/day | Rp. 65000/day
Asisten Tukang 2 | Work 100% | Rp. 45000/day | Rp. 65000/day
Asisten Tukang 3 Work 100% | Rp. 45000/day | Rp.65000/day
Tukang Keramik Work 100% | Rp. 65000/day | Rp. 85000/day
Asisten Tukang Work 100% | Rp.50000/day | Rp.75000/day
Keramik
Ahli Taman Work 100% | Rp.75000/day | Rp. 100000/day
Asisten Ahli Work 100% | Rp.65000/day | Rp. 85000/day
Taman
Semen Material | - Rp. 75000 -
Pasir Material | - Rp. 100000 -
Keramik Material | - Rp. 65000 -
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lengkap yang memungkinkan kita untuk mendapatkan informasi biaya
proyek, meratakan sumber daya yang berbeban lebih, dan lain-lain.

B Untuk coss resource, tidak terdapat informasi tambahan yang bisa
dimasukkan, sifatnya hanya untuk catatan saja. Khusus cost resource
biayanya akan dimasukkan langsung pada saat mengalokasikan
resource ini pada suatu kegiatan. Contoh kongkrit dari jenis resource

5.1 Membuat Daftar Sumber Daya Proyek

Untuk membuat daftar sumber daya, anda dapat menggunakan menu View
> Resource Sheet di dalam MS Project 2007. Sumber daya dapat bervariasi

dari orang, perlengkapan, maupun materi yang dibutuhkan untuk
melaksanakan kegiatan.

ini adalah ongkos sewa mesin, sewa peralatan dan lain-lain.

Tabel 5.1 Daftar Sumber Daya / Resource Proyek

Resource Name Type Max Std. Rate Ovt. Rate
Unit
1. Dari menu View, klik Resource Sheet
’ : 0 . 75000/d Rp. 100000/da
2. Dari menu View, klik ke Tuble, dan klik Entry Arsitek Work 100% | Rp.75 ay p y
3. Di dalam field Resource Name, ketik nama dari sumber daya beserta Mandor 1 Work 100% | Rp.65000/day | Rp. 85000/day
informasi detil lainnya yang berhubungan dengan jenis sumber daya Mandor 2 Work 100% | Rp. 65000/day | Rp. 85000/day
terscbut. Tukang Bata 1 Work | 100% | Rp.50000/day | Rp.75000/day
4.  Untuk memasukkan sumber daya-sumber daya di dalam suatu grup, % | Ro. 50000/ Ro. 75000/da
ketik nama grup di dalam Group field Tukang Bata 2 Work 100% | Rp. A A
5. Di dalam field Type, sebutkan tipe sumber daya: Tukang Bata 3 Work 100% | Rp.50000/day | Rp.75000/day
a.  Untuk work resource (orang atau perlengkapan), set resource type Asisten Tukang 1 | Work 100% | Rp. 45000/day | Rp.65000/day
menjadi Work Asisten Tukang 2 | Work | 100% | Rp.45000/day | Rp.65000/day
b.  Untuk material resource (yang dikonsumsi sepanjang proyek), set 100% | Ro. 4500074 Ro. 63000/da
b . a .
resource type menjadi Material Asisten Tukang 3 Work b p y ) y
¢.  Untuk cost resource (resource yang membutuhkan biaya, misalnya Tukang Keramik Work 100% | Rp.65000/day | Rp.85000/day
sewa), set resource type menjadi Cost Asisten Tukang Work 100% | Rp.50000/day | Rp.75000/day
6. Untuk setiap work resource, ketik jumlah unit sumber daya yang tersedia Keramik
untuk sumber daya ini di dalam Max unit Jeld, sebagai persentase. Ahli Taman Work 100% | Rp.75000/day | Rp.100000/day
Misalnya, ketik 300% untuk mengindikasikan 3 full-time unit dari Asiston ABL Work 100% | Rp.65000/day | Rp.85000/day
sumber daya tertentu. Masukkan juga std rate (tarif standar) dan ov# Taman
rate (‘t%rl'f lenilbur) dari sumber daya.ters?but. Work resource juga bisa Sermon Matorial | - Rp. 75000 _
memiliki basis kalender khusus apabila diperlukan.
7. Untuk setiap material resource, ketik di dalam field Material label, unit Pasir Material | - Rp- 100000 _
pengukuran untuk unit tersebut, misalnya ton. Keramik Material | - Rp. 65000 -
58

¥ Panduan Lengkap Mengelola Proyek dengan Microsoft Project Professional 2007

Menentukan Suatu Kegiatan pada Sumber Daya yang Dimiliki 8 59




Resource Name Type Max Std. Rate Ovt. Rate
Unit
Kayu Material | - Rp. 125000 -
Genting Material | - Rp. 5000 -
Batu Kali Material | - Rp. 50000 -
Pipa PVC Material | - Rp. 45000 -
Kabel Listrik Material | - Rp. 10000 -
Pagar Besi Material | - Rp. 150000 -
Truk Cost - - -
Penggiling Semen | Cost - - -

Catatan:

*  Untuk material resource, satuan yang kita tentukan tergantung asumsi
kita, misalnya untuk pasir kita asumsikan harga satu truk, semen adalah
sak, keramik satu boks, dan lain - lain.

Sebelum kita memasukkan informasi resource seperti yang ditunjukkan
di tabel 5.1, kita perlu mengubah satuan mata uang yang awalnya adalah
dollar Amerika untuk berubah menjadi rupiah. Caranya adalah dengan
memilih menu Tools > Options dan pada tampilan Options pilihlah Tab
View. Ubahlah informasi Currency options menjadi IDR.

Setelah semua Resource diatas dimasukkan dalam Resource Sheet maka

tampilannya adalah sebagai berikut (lihat juga bab 6 mengenai “Cara
Menghitung Biaya Proyek”):
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e

Dotk yiows [ Gankt Chart ,, :
" Calenger type: | Calondar

Date format:

*[Mon 1/28/02

Gambar 5.1 Mengubah Satuan Mata Uang Menjadi Rupiah

Catatan:
*  Untuk mengganti tarif yang sebelumya perjam atau /hr, cukup dituliskan

nilainya kemudian diikuti garis miring dan satuan perhari yaitu /d (atau
satuan lain yang dibahas sebelumnya misalnya mo untuk bulanan.

SETE v e o K n v W R ETEN E R NS R

Gambar 5.2 Tumpilan Resource Sheet di MS Project
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*  Padasalah satu kolom terdapat cos#/use, ini dipergunakan apabila setiap
pemakaian resource membutuhkan biaya tambahan (misalnya setiap
penyewaan truk terdapat biaya administrasi).

*  Apabila terdapat resource yang berupa sebuah mesin, resource tersebut
dapat dianggap sebagai work resource dengan perhitungan tarifnya
diperhitungkan dari biaya listrik dan biaya depresiasinya.

5.2 Mengganti Jadwal Kerja Sumber Daya

Waktu kerja dan waktu tidak kerja telah didefinisikan sebelumnya, yang

mana by default sudah ditentukan. Jika seorang individu bekerja pada

berbagai jadwal, atau jika anda membutuhkan perhitungan untuk adanya

liburan atau waktu downtime perlengkapan, anda dapat memodifikasi

kalender sumber daya dari setiap individu dari resource.

1. Didalam menu View, pilih Resource Sheet, kemudian pilih resource yang
ingin diganti jadwalnya

2. Dari menu Project, klik Resource Information, kemudian klik Working Time tab

3. Darikalender, pilih hari yang ingin diganti, kemudian untuk mengganti
keseluruhan kalender, seperti sebelumnya, pilih singkatan yang ada di

kolom teratas di kalender. Penjelasan tentang pengubahan ini terdapat
di bagian 2.3 di buku ini.

Gambar5.3 Tampilan Informasi Resource
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4. Apabila scbuah resonrce menggunakan basis kalender yang sama sekali
berbeda dari yang lainnya, sebaiknya menggunakan basis kalender
baru khusus untuk resource tersebut dengan memilih basis kalender
di View Resource Sheet di kolom Base Calendar. Cara membuat basis
kalender yang baru telah dijelaskan di bagian 2.4 buku ini.

5.3 Mengalokasikan Sumber Daya untuk Kegiatan-kegiatan

Kita dapat mengatur sumber daya untuk suatu kegiatan, dan dapat
mengubahnya kemudian dengan mudah sebagaimana diperlukan. Jika ada
sumber daya yang overload, atau melebihi kapasitasnya, MS Project 2007
akan memberikan tanda merah sebagai peringatan.

1. Dari menu View, pilih Ganzt Chart
2. Dari field Task Name, pilih kegiatan yang ingin diberikan sumber
dayanya, kemudian klik kanan Task Information,dan pada tab Resources
atau menu Zools > Assign Resources (Alt + F10).
3. Di dalam field Name, klik sumber daya yang ingin ditempatkan di
kegiatan tersebut
4. Untuk sumber daya dialokasikan secara part-time, ketik atau
pilih persentase kurang dari 100% di dalam kolom max. unit pada
Resource Sheet untuk menunjukkan persentase waktu kerja yang ingin
dialokasikan oleh sumber daya tersebut untuk kegiatan tersebut
a. Untuk menempatkan lebih dari satu sumber daya, tekan tombol
CTRL dan klik nama-nama sumber daya
b. Untuk menempatkan lebih dari 1 untuk sumber daya yang sama,
ketik atau pilih persentase lebih dari 100% di dalam kolom unit.
Jika diperlukan, ketik nama dari sumber daya.

5. Click Assign, kemudian Close.

Dalam studi kasus proyek pembangunan rumah, daftar resources yang
dipergunakan untuk setiap kegiatan adalah sebagai berikut:
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Tabel 5.2 Daftar Penugasan Resource untuk Proyek Pembangunan !

Rumah
Nama Tugas Work Resource Material Cost
(Taks Name) Resource Resource
Penyiapan
Lahan
Pengukuran Mandor 1 - -
Tanah Tukang Bata 1
Asisten Tukang 1
Pembuatan Mandor 1 - -
Patok Tukang Bata 1
Penggalian Asisten Tukang 1
Pemeriksaan Arsitek
Patok Pengukur
Pembangunan
Pondasi
Penggalian Tukang Bata 1 - -
Pondasi Tukang Bata 2
Tukang Bata 3
Asisten Tukang 1
Asisten Tukang 2
Asisten Tukang 3
Pengurukan Asisten Tukang 1 | Pasir (3 truk) Truk
Pasir Asisten Tukang 2 (Rp. 150000)
Asisten Tukang 3
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Nama Tugas Work Resource Material Cost
(Taks Name) Resource Resource
Penyusunan Tukang Bata 1 Pasir (4 truk) Penggiling
Pondasi Tukang Bata 2 Semen (10 sak) | Semen
Tukang Bata 3 Batu Kali (Rp. 300000)
Asisten Tukang 1 | (5 truk)
Asisten Tukang 2
Asisten Tukang 3
Mandor 2
Pengeringan Arsitek - -
Pondasi Mandor 2
Pemeriksaan Arsitek - -
Pondasi
Penyusunan
Tembok
Pengaturan Mandor 1 - -
Pengecoran Mandor 2
Otot Tukang Bata 1
Asisten Tukang 1
Arsitek
Pengecoran Tukang Bata 1 Pasir (3 truk) Penggiling
Otot Pondasi | Tukang Bata 2 Semen (7 sak) | Semen
Tukang Bata 3 Batu Kali (Rp. 200000)
Asisten Tukang 1 | (2 truk)
Asisten Tukang 2
Asisten Tukang 3
Mandor 1
Pengeringan Arsitek - -
Otot Pondasi Mandor 2
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Nama Tugas Work Resource Material Cost
(Taks Name) Resource Resource
Penyusunan Tukang Bata 1 Pasir (5 truk)
Tembok Bata Tukang Bata 2 Semen (15 sak)
Tukang Bata 3
Asisten Tukang 1
Asisten Tukang 2
Asisten Tukang 3
Mandor 1,
Arsitek (50%)
Pemasangan Tukang Bata 3 Kayu
Kusen Asisten Tukang 3 | (4 m kubik)
Pemasangan Tukang Bata 2 Pipa PVC (20
Pipa Listrik Asisten Tukang 2 | pipa)
Pemeriksaan Arsitek -
Tembok Mandor 2
Penyusunan
Atap
Pemasangan Tukang Bata 1 Kayu
Kuda - Kuda Tukang Bata 2 (8 m kubik)
Atap Asisten Tukang 1
Asisten Tukang 2
Pemasangan Tukang Bata 1 Kayu
Kayu Usuk Tukang Bata 2 (10 m kubik)
Asisten Tukang 1
Asisten Tukang 2
Pemasangan Tukang Bata 1 Kayu
Kayu Reng Tukang Bata 2 (12 m kubik)
Asisten Tukang 1
Asisten Tukang 2
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Nama Tugas Work Resource Material Cost
(‘luks Name) Resource Resource
Pemasangan Asisten Tukang 1 | Genting
Genting Asisten Tukang 2 | (5000 buah)
Asisten Tukang 3
Pemeriksaan Arsitek
Atap Mandor 1
Mandor 2
Pengerjaan
Interior
Plester Tembok | Tukang Bata 1 Pasir (2 truk)
Tukang Bata 2 Semen (10 sak)
Asisten Tukang 1
Asisten Tukang 2
Pengecatan Tukang Bata 1 -
Tembok Tukang Bata 2
Asisten Tukang 1
Asisten Tukang 2
Pemasangan Tukang Bata 3 - -
Listrik Asisten Tukang 3
Pemasangan Tukang Keramik | Keramik (20 -
Lantai Keramik | Asisten Tukang boks)
Keramik
Mandor 1
Pemasangan Tukang Bata 3 Pasir (2 truk) -
WC / Kamar Asisten Tukang 3 | Semen (5 sak)
Mandi
Pemasangan Tukang Bata 1 Pasir (1 truk) -
Dapur Asisten Tukang 1 | Semen (4 sak)
Pemeriksaan Aursistek - -
Interior Mandor 1
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Nama Tugas Work Resource Material Cost
(Taks Name) Resource Resource
Pengerjaan
Eksterior
Pemasangan Tukang Bata 1 Pipa PVC (10 | -
Jalur PDAM Asisten Tukang 1 | pipa)
Pengerjaan Tukang Bata 2 Pagar Besi -
Pagar Asisten Tukang 2 | (10 meter)
Pengerjaan Ahli Taman - -
Taman Asisten Ahli
Taman
Penyerahan ke | Arsitek - -
Pemilik

Untuk menugaskan resources ke dalam suatu task, caranya dengan mendobel
klik nama kegiatan dan pada Task Information di Resources, tambahkanlah
Resources yang dibutuhkan. Tambahkan pula unit sesuai yang dibutuhkan
(100% berarti seluruh waktu dipakai untuk kegiatan tersebut, 50% berarti
paruh waktu). Cos# atau biaya akan otomatis terisi berdasarkan informasi
tarif yang sebelumnya sudah dimasukkan.

Gambar 5.4 Menambabkan Resources pada Suatu Task
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Untuk pemakaian resource yang berupa material resource, nTasukkzm jumlah
unit yang dipakai, misalnya untuk kegiatan Pengurukan Pasir m‘embutuhkan
3 truk. Sedangkan untuk resource Truk yang termasuk kategori cost resource,
langsung masukkan biaya yang dibayarkan, misalnya Rp. 150000.

T

(iRp150,000 )

S

Gambar 5.5 Pengisian Material dan Work Resources

Untuk work resource yang paruh waktu, masukkan nilai paruh waktunya.
Misalnya untuk kegiatan Penyusunan Tembok Bata resource Arsitek hanya

paruh waktu 50%.

[Tokang 100% Rp500,000
:mmi 100% Rp500,000
T ‘Adstenfduigl 100% Rp450,000
| Thsisten Tukang 2 100% Rp450,000

Gambar 5.6 Pengisian Work Resource Parub Waktu
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7

Tampilan View > Gantt Chart untuk proyck pembangunan perumahan
sctelah pengalokasian resources adalah sebagai berikut:
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Gambar 5.7 Tampilan Proyek di MS Project 2007 Setelih Penugasan
Resources

Catatan:

*  Untuk memberikan estimasi yang lebih baik pada saat perencanaan
proyek seperti pada proyek ini, kita dituntut untuk lebih kreatif
Misalnya untuk resource-nya mungkin kita perlu tambahkan sambil
jalan, contohnya kegiatan Pengecatan Tembok pasti membutuhkan
material resource Cat Tembok, juga kegiatan Pemasangan Listrik pasti
membutuhkan material resource berupa Kabel Listrik, Stop Kontak,
Colokan Listrik dan lain - lain.

5.4 Check dan Edit Resource Assignments

Untuk melakukan pengecekan, dapat digunakan menu View > Resource
Usage. Dengan ini anda akan dapat menemukan berapa banyak waktu
yang dibutuhkan oleh setiap sumber daya untuk bekerja pada kegiatan
yang spesifik dan melihat apakah sumber daya tersebut sudah overallocared
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(melebihi kapasitasnya). Resource yang dialokasikan berlebih akan berwarna
merah. Dari menu View, klik Resource Sheet. Untuk resource yang melebihi
kapasitas akan terlihat berwarna merah.

U AR

it

P ST S T T T
Gambar 5.8 Warna Merah Menandakan Resource Overallocation

Untuk mengubah overallocated resources, sehingga dapat menjadi benar
kembali, dapat dilakukan secara otomatis, yaitu melalui Leveling Resources.
Konsekuensinya adalah mengubah waktu kerja (penjadwalan dari sumber
daya tersebut). MS Project 2007 dapat melakukannya secara otomatis

dengan cara:

Pilih menu View > Resource Sheet

Kemudian pada menu View, pilih bagian Table: Entry

Selanjutnya, pilih menu 7ools > Level Resources, sebuah tampilan dialog
bernama Resource Levelling akan muncul

Pada field Leveling Calculation pilih manual, pada drop-down menu
Look for overallocation pilih Day-by-day, Clear Leveling Values check
box harus tercentang
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5. Pada bagian Leveling range pilih Entire Project, pada bagian Leveling
order pilih Standard. (
6. Pada bagian Resolving overallocation di Level Only Within Available
Slack tidak tercentang, untuk memungkinkan pengunduran end-date,

sedangkan Leveling can adjust individual assignments on task harus
tercentang

7 Leveling caléulations ——~ e
f O automatic ‘ @ Manual
 ookforperaloctons an . B2y 0oy
| [F]ear leveing values before leveling

e fa Wpro
? (© Level entire project

E Ol ‘T From: i'Monl[é
L To: E":e'—j e
¢ Resolving averallocations o

H

| Lovelngorder: - [Standerd " I¥] |

i e

! []tevel only within avadable slack
1 [¥]Levelng can adiust individual assignments on a task V

t
i«DLevdTmuthﬂleg’opos,edboohwgtype :

(o] [ ol

Cancel .

Gambar5.9 Tampilan Resource Levellin g

7. Klik pada tombol Leve/ Now untuk memulai proses Resource Levelling

8. Sebuah tampilan kecil Leve/ Now akan muncul, pilihlah konfirmasi
pada Entire Pool dan klik OK.

Gambar 5.10 Pemiliban Tingkat Levelling
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Sctelah ini maka resources yang sebelumnya berwarna merah akan berubah
menjadi hitam karena sudah tidak overa/located. Namun sering juga terjadi
bahwa MS Project 2007 tidak menemukan cara terbaik untuk Resource
levelling sehingga masih terdapat yang berwarna merah. Kita harus
mclakukan pengubahan secara manual pada penugasan resources yang ada.
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Gambar 5.11 Hasil Resource Levelling

Catatan: Apabila Resource Levelling tidak bisa berjalan dengan sempurna,

maka langkah-langkah yang dapat kita lakukan:

*  Melihat di View > Resource Graph untuk menemukan sumber daya
yang kelebihan beban (biasanya ditandai dengan warna merah).

*  Atau melihat di View > Resource Sheet untuk melihat detil pembagian
kerja dari masing - masing resource berdasarkan waktunya. Resource
yang kelebihan beban akan juga ditandai dengan warna merah pada
detil jumlah jamnya.

*  Melakukan perbaikan manual, misalnya menugaskan kegjatan tersebut pada
orang lain, atau menggeser waktu pelaksanaan kegiatan yang bertumpukan
yang dilakukan oleh resource yang sama agar tidak kelebihan beban.

*  Mengulang proses Resource Levelling.
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Untuk melihat perbedaan antara penjadwalan sumber daya sebelum dan
sesudah /eveling, dapat dilakukan dengan cara: View > More Views. Scbuah

tampilan akan muncul menanyakan view baru yang diinginkan. Pilihlah
Leveling Gantt dan tekan tombol Apply.

re

—
X
a3

Views:
@ew’zeﬁnq’ Gantt T

Milestone Date Rollup
Milestone Rollup
Multiple Baselines Gantt
Network Diagram
Relationship Diagram
Resource Allocation
Resource Form
|Resource Graph
Resource Name Form
Resource Sheet

Gambar 5.12 Pemiliban View Baru

Setelah itu maka pada tampilan Gantt Chart terdapat dua bagian gambar

pada masing - masing sas#, bagian yang (defauls) hijau adalah sebelum dan
yang biru adalah sesudah leveling.
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Gambar 5.13 Me/ibat Perbedaan Gantt Chart Sebelum dan Sesudah Levelling
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5.5 ‘Tentukan Kapan Biaya Akan Terkumpul

Di dalam MS Project 2007, biaya sumber daya dihitung secara prorared
sccara default, yaitu sejalan dengan persentase penyelesaian kerja yang
dilakukan. Hal ini dapat diganti sebagaimana perlu, dengan menggunakan
accrual method, sehingga pembayaran/biaya yang dikeluarkan baru
berlaku pada awal atau akhir dari kegiatan tersebut Contoh nyata dari
metode ini adalah pembayaran dari pekerja yang bersifat borongan yang
pembayarannya dilakukan diakhir.

Pada contoh kasus kita kali ini semua tukang dan asistennya akan kita ubah
metode penghitungan biayanya secara accrual. Caranya adalah:

1. Dari menu View, klik Resource Sheet
. Dari menu View, pilih Table, kemudian klik Entry
3. Di dalam field Accrue At, pilih metode accrual yang ingin digunakan,
misalnya End yang artinya biaya akan dihitung pada akhir kegiatan.
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Gambar 5.14 Mengganti Tipe Pembayaran Resources
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Catatan:

*  Accrue at End berarti pembayaran dilaksanakan di akhir kegiatan.

*  Accrue at Start berarti pembayaran dilaksanakan di awal kegiatan.

*  Proses pengubahan ini tidak akan mempengaruhi informasi biaya
proyek seperti yang ditunjukkans sebelumnya, namun mempengaruhi

penghitungan biaya yang sudah dibayarkan pada saat tahap pelacakan
proyek (bab 8 buku ini).

5.6 Melihat Biaya Dari Sumber Daya Tertentu

Setelah dipilih suatu tarif, anda mungkin ingin mereview biaya total untuk

meyakinkan apakah biaya tersebut sesuai dengan harapan anda. Jika total

biaya dari suatu sumber daya tidak sesuai dengan anggaran anda, anda

mungkin ingin memeriksanya dan mencari di bagian mana biaya bisa

dikurangi.

1. Untuk melihat biaya suatu sumber daya, dari menu View, klik Resource
Sheet

2. Dari menu View, pilih Table, dan klik Cost.

Gambar 5.15 Tampilan Biaya Untuk Resources Proyek
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5.7 Menentukan Biaya Keseluruhan Suatu Proyck

MS Project 2007 dapat menghitung tarif baik untuk pekerja, material dan
biaya lainnya, sehingga anda dapat mengatur proyek dengan lebih akurat.
Anda dapat menggunakan standard rates, overtime rates, atau per-use rates
sesuai dengan kebutuhan. Cara memasukkan biaya pada resources telah
ditunjukkan pada bagian 5.1 buku ini.

Apabila semua data telah dimasukkan, maka sekarang ini MS Project
2007 dapat memberikan informasi yang lengkap mengenai biaya proyek.
Caranya adalah memilih menu Project > Project Information, kemudian
pada tampilan Project Information tekanlah tombol Statistics yang terletak
pada bagian bawah:

A
Srart: Firish
rent Mon 1/5/09 Wed 4/22/09
Baseline NA "
Actual : & =
Yariance T od o
AR QU B m ‘CW‘!" )
N-Curent 7759 3,00 TS
Baseline odr - oo
Actual od - oh g0
Remairing | 77.5d Lo . 3,004h RpS9,437,500
~Percert complete: - ey :
[ M

Gambar 5.16 Informasi Biaya Proyek

Dari gambar diatas, dapat diketahui beberapa hal penting yaitu:
+  Proyek dimulai tanggal 5 Januari 2009 dan berakhir tanggal 22 April

2009
+  Lama proyek adalah 77.5 hari dengan total pekerjaan sejumlah 3004

jam.
+  Biaya proyek adalah Rp. 59.437.500

Pada bagian paling bawah terdapat informasi tentang Percent complete yang
semuanya masih 0%, hal ini dikarenakan pada saat ini proyek masih belum
memasuki tahapan selanjutnya yaitu tracking atau pelacakan.

-00000-
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Bah 6
Melihat Jadwal dan Detilnya

etelah memasukkan semua data yang mendasar, sekarang waktunya
me-review. Apakah proyek akan memenuhi deadline? Jika tidak, perlu
dilihat yang mana yang merupakan milestone dan pastikan lagi bahwa
jadwal sudah disusun dengan efisien.
Pertama, lihat pada gambaran keseluruhan: dari tanggal stars dan finish,
kemudian pada critical path yaitu garis kegiatan di mana urutan tersebut
yang menjadi penentu penyelesaian proyek. Kemudian periksa detailnya.

6.1 Melihat Keseluruhan Proyek pada Layar Monitor

Anda dapat mendapatkan gambaran keseluruhan proyek dari starz ke finish
dan melihat fase-fase utama yang akan muncul dengan melakukan zoom in
atau zoom out dari Gantt Chart

1. Dari menu View, klik Gantt Chart
2. Dari menu View, klik Zoom, kemudian Entire Project, dan klik OK
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Gambar 6.1 Melibar Proyek Secara Keseluruban

6.2 Memeriksa Tanggal Start dan Finish Proyek

Ancila dapat melihat informasi proyek yang penting seperti finish date, untuk
melihat apakah proyek sudah sesuai dengan harapan.

1. Dari menu Project, klik Project Information, kemudian klik Statistics

2. Disitu terlihat tanggalnya selesain i
ya proyek berdasarka hitu
dari MS Project. S

RS TS . : j 437,500

Gambar 6.2 Informasi Awal dan Akkir Proyet,
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6.3 ldentifikasi Jalur Kritis atau Critical Path

Critwal path adalah suatu seri kegiatan yang harus diselesaikan pada
waktunya supaya proyek dapat diselesaikan sesuai jadwal atau bisa dikatakan
juga rantai kegiatan yang terpanjang. Kebanyakan kegiatan dari proyek
yang biasa memiliki beberapa slack (kesenggangan waktu) sehingga dapat
ditunda sedikit tanpa mempengaruhi tanggal finish proyek. Tapi untuk
critical path, hal ini tidak bisa dilakukan. Pada waktu modifikasi dilakukan,
hati-hati perhatikan apakah kegiatan-kegiatan ini terpengaruh.

1. Dari menu View, pilih Gantt Chart
2. Klik kanan pada tanggal, kemudian pilih Gan#t Chart Wizard
3. Akan terdapat tampilan awal dari Gantt Chart Wizard, tekanlah

tombol Nex# untuk melanjutkan ke proses selanjutnya.

Wakcoms to the Gantt Chart Wizard.,

Gambar 6.3 Tampilan Awal Gantt Chart Wizard

4. Tampilan berikutnya menanyakan informasi apa yang ingin
ditampilkan, pilihlah Critical path dan tekan tombol Next.
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What kind of Information do you want to display in
rm Gantt Chart? yod your

Gambar 6.4 Piliban Informasi yang Ingin Ditampilkan

5. Tampilan berikutnya menanyakan informasi tambahan apakah yang
ingin ditampilkan pada balok - balok kegiatan di Gantt Chart. Pilihlah
Resources and dates untuk menampilkan baik Resources dan tanggal pada
setiap kegiatan yang digambarkan.

* Wht task information do you want o disply wih
Ganttbarsy T ekt dsplay wih your

(®Resour es and dates
ORBSU ey
Opates = .
Oigne ’
Octstmta‘dcﬁfomaﬁon

LCW“TAL?Mﬂum& V[ )

Gambar 6.5 Piliban Informasi pada Task di Gantt Chart
6. Tampilan berikutnya menanyakan apakah ketergantungan antar

kegiatan (fask dependencies) perlu ditampilkan juga. Pilihlah Yes dan
tekan tombol Next.
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| O— - Ome

“—‘I;' ©Yes
Sue

Do you want to show link lines between dependent tasks?

(o) e (o)

Gambar 6.6 Piliban Menampilkan Ketergantungan Antar Kegiatan

7. Tampilan berikutnya berisi informasi bahwa proses pengumpulan
informasi untuk proses Ganzt Chart Wizard telah selesai. Tekan tombol
Format It untuk memulai proses pengubahan pada Ganzt Chart.

P ——— The Garkt Chart Wizard is ready to Format your Gantt ">

L Sue " To change your selections, thoase the Back ‘:"to;’

Congratulations!

retum to the dialog box you want,

o T v wa

Gambear 6.7 Tampilan Sebelum Pengubahan

8. Tampilan terakhir akan menginformasikan bahwa proses pengubahan
pada Gantt Chart telah selesai. Tekan tombol Exiz Wizard untuk

menutupnya.
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Your Gantt Chart is finished!

For more information about formatting Chart
search Help for Gantt Chart. your Gentt Chart,

Firich

C et

Gambar 6.8 Proses Pen gubaban Telah Selesai

Tampilan Gantt Chart akan berubah, warna merah menandakan suatu
kegiatan yang berada di jalur kritis (Critical Pazh) yang berarti tidak boleh
terdapat penundaan pada kegiatan tersebut tanpa mengorbankan waktu
penyelesaian proyek. Kegiatan yang berwarna biru tidak dalam jalur kritis

schingga bisa kita pindahkan waktunya dan tidak membahayakan waktu
akhir dari proyek.
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Gambar 6.9 Gantt Chart dengan Critical Path Berwarna Merah
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6.4 Memahami Fleksibilitas Jadwal Kegiatan

Jalur kritis atau Critical Path adalah jalur Kegiatan-kegiatan proyek yang
bersifat kritis. Kritis disini bukan dalam artian jenis pekerjaannya yang
sangat penting namun hanya dalam segi waktu. Kegiatan-kegiatan yang
berada dalam critical path memiliki sifat yang tidak boleh ditunda sedikitpun.
Apabila sebuah kegiatan di jalur kritis tertunda, maka keseluruhan waktu
penyelesaian proyek juga tertunda. Sebaliknya apabila sebuah kegiatan di
critical path selesai lebih cepat, maka penyelesaian proyeknya juga akan
lebih cepat.

Bagaimana dengan Kegiatan-kegiatan lainnya yang tidak berada dalam

jalur kritis? Kegiatan tersebut lebih fleksibel dalam arti waktunya masih

bisa sedikit tertunda, agak molor namun tidak akan membahayakan waktu

penyelesaian proyek. Tingkat fleksibilitas suatu kegiatan terhadap waktu

ditentukan oleh lima buah variabel yaitu:

*  Late Start: pada tanggal berapakah sebuah kegiatan paling lambat
harus sudah dimulai.

Late Finish: pada tanggal berapakah sebuah kegiatan paling lambat
harus sudah selesai.

Free Slack: waktu yang diperbolehkan untuk sebuah kegiatan dapat
molor tanpa mengorbankan permulaan kegiatan berikutnya.

s Total Slack: waktu yang diperbolehkan untuk sebuah kegiatan dapat
molor tanpa mengorbankan akhir penyelesaian proyek.

Untuk studi kasus kita, informasi diatas dapat dilihat dengan cara:

1. Memilih menu View > Gantt Chart
2. Memilih menu View > Table > Schedule
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Gambar 6.10 Informasi Late Start, Late Finish, Free Slack,
dan Total Slack

Catatan:

*  Kegiatan-kegiatan yang berada dalam critical path pasti memiliki
tanggal /ate start dan late finish yang sama dengan tanggal star¢ dan
Senishnya.

*  Kegiatan-kegiatan yang berada dalam critica/ path juga memiliki nilai
JS7ee slack dan total slack O yang artinya kegiatan-kegiatan tersebut sama

sekali tidak fleksibel dalam hal waktu.

6.5 Merekam Rencana Baseline

Setelah semua persiapan pelaksanaan proyek sudah selesai, maka disamping
kita perlu menyimpan berkas proyek tesebut, kita juga perlu menyimpan
baseline sebagai tolok ukur dalam memonitor pelaksanaan proyek nantinya
yang berisi Kegiatan-kegiatan, resource dan penugasannya. Dalam MS
Project 2007 kita dapat menyimpan sampai 11 buah Jaselines. Untuk
merekam baseline plan, anda dapat melakukan hal berikut:
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Dari ienu 7ools, point pada Tracking, dan kemudian klik Set Baseline
Pilihlah nama baseline yang ingin direkam, pilihannya adalah Baseline,
Baselinel, Baseline 2 sampai dengan Baseline 10.

Klik Entire project untuk merekam project baseline.

Klik OK

: }Baseﬁﬂe, ,k ’k k’ ——e sl

S l Ik

Lo ]

Cpntee [Ehart {Finish
@ eqtire project
- Oselected tasks

 Roll up baselines: i

Gambar 6.11 Merekam Baseline Proyek

Catatan:

*  Kita dapat menghapus baseline yang sebelumnya telah dihapus dengan
memilih Tools > Tracking > Clear Baseline. Dan pilihlah baseline yang
ingin dihapus.

*  Apabila kita sudah memiliki beberapa baseline yang sudah direkam,
kita dapat membandingkan antara satu baseline dengan yang lainnya
dengan memilih menu Views > More Views. Kemudian pilihlah Multiple

Baselines Ganrt dan kemudian tekan tombol Apply.
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Gambar 6.12 Memilip Multiple Baselines Gantt

Tami.)ilan Gantt Chart akan menampilkan perbandingan antara baseline -
baseline yang sudah kita rekam dengan berbagai macam warna.

S— i

Gambar 6.13 Membandingkan Berbagai Baseline

6.6 Merekam Sebuah Interim Plan

.Disafnping merekam baseline dari sebuah proyek, kita jugadapat menyimpan
interim plan dari proyek juga. Sebuah interim plan dapat dipergunakan

-
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untuk menyimpan jejak rekam dari scbuah proyek yang lebih ditekankan
dari start dan finish dari rangkaian kegiatan-kegiatan (tujuannya untuk
dapat dibandingkan dengan éasefine plan apakah Kegiatan-kegiatan yang
ada maju atau mundur dari rencana). Di MS Project 2007 kita juga dapat

menyimpan sampai 11 inferim plan.

Klik Set interim plan

Wb

tentukan nama yang baru

Dari menu 7vofs, point ke Tracking, kemudian klik Sez Baseline

Di dalam Capy box, klik nama inserim plan yang sekarang
Di dalam Info box, klik nama untuk inferim plan berikutnya, atau

5. Klik Entire projectuntuk merekam suatu interim planuntuk keseluruhan
proyek. Klik Selected tasks untuk merekam hanya sebagian saja dari

jadwal
6. Klik OK

regd o S 21144030
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Gambar 6.14 Merekam Interim Plan Proyek
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Dalam t:lh;qf:m ini segala persiapan pelaksanaan proyek dapat dianggap
sudah selesai dan proyek siap untuk dijalankan. Tahapan berikutn

dari proyek .adalah proses pelacakan atau monitoring dari proyek dZ’: Bab 1
melakukan tindakan-tindakan apabila proyek mengalami keterlambatan

atau permasalahan lainnya. Me mon i tO r Pe la kSa Naan
-000o0- Kegi ata n PrOye k

ekali Anda menetapkan proyek dan pekerjaan telah dimulai, anda

dapat memonitor pelaksanaan sesungguhnya, yaitu acfual start, actual
finish dates, persentase penyelesaian, dan pekerjaan sesungguhnya. Dengan
mengamati apa yang terjadi, akan terlihat bagaimana perubahan-perubahan
mempengaruhi kegiatan-kegiatan lainnya, yang juga dapat mempengaruhi
penyelesaian proyek. Informasi biaya dari proyek dapat kita masukkan
sehingga informasi mengenai biaya yang sudah dikeluarkan sampai saat
tersebut beserta prediksi apakah anggaran akan melebihi atau tepat dapat

diperkirakan dengan baik.

Dengan memasukkan informasi penyelesaian kegiatan dan biaya dengan
benar dari awal, maka segala macam permasalahan yang mungkin terjadi
dapat diantisipasi dengan baik. Dengan bantuan MS Project 2007 maka
kita dapat melakukan perkiraan berdasarkan data yang kita masukkan saat
itu yang berhubungan dengan perkiraan waktu penyelesaian proyek dan
juga perkiraan biaya yang akan dihabiskan oleh proyek. Apabila ternyata
meleset maka kita dapat melakukan langkah-langkah antisipasi agar
jalannya proyek dapat kembali seperti semula.
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7.1 Memeriksa Apakah Kegiatan Dilaksanakan Scsuai Rencana Catatan:

. — e Pada Tracking Gantt akan terdapat dua buah garis di setiap balok
Untuk menjaga han j i iy, . g P & p

jaga pemenuhan jadwal, yakinkan bahwa kegiatan mulai kegiatan dimana yang dibawah (warna hitam) akan menunjukkan

dilaksanakan dan diselesaikan pada waktunya. Tracking Gantt view dapat perkembangan dari proyek

rr.lenol(?ng untuk rr.lencari titik permasalahan, kegiatan yang bervariasi *  Untuk sekarang ini perkembangan proyek semuanya 0% karena
dibandingkan éaseline plan. Dengan demikian anda dapat menyesuaikan
sumber daya, fask dependencies, atau menghapus beberapa kegiatan untuk
mengejar deadlines.

informasi perkembangan proyek belum dimasukkan.

2. Untuk melihat field Variance, dari menu View, point ke Table, dan klik

Tracking Gantt view memasangkan jadwal yang sesungguhnya dengan Variance

rencana awal untuk setiap kegiatan. Setiap kali anda memasukkan
pelaksanaan sesungguhnya, akan terlihat bahwa ada bar yang bergeser
menunjukkan bagaimana pelaksanaan dibandingkan dengan baselinenya.

1. Dari menu View, klik Tracking Gantt
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Gambar 7.2 Tampilan Variance pada Tracking Gantt Chart

3. Jika diperlukan, klik Z24B untuk melihat Variance fields

4. Apabila belum terdapat Tracking toolbars, pilihlah dari menu View,
, point ke Toolbars, dan kemudian klik Tracking. Sebuah foolbar untuk
S P memasukkan perkembangan kegiatan akan muncul.

Gambar 7.1 Tampilan Tracking Gantt Chart

$0%.75% 1007

0% PS%

R

Gambar 7.3 Toolbar untuk Tracking Proyek
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Catatan:

5.

Kita dapat memasukkan perkembangan suatu kegiatan dalam proyck
dengan cara memilih kegiatan yang akan kita perbaharui, kemudian
memilih salah satu tombol pada toolbar diatas.

"Tombol - tombol yang terdapat dalam Toolbar diatas:

0 Project Statistics: menunjukkan statistik dari proyek.

o  Update as scheduled: kegiatan telah dilaksanakan sesuai jadwalnya

o Add progress line: menambahkan garis perkembangan pada balok
kegiatan.

o Tombol prosentase 0%, 25%, 50%, 75%, 100%: untuk memperba-
harui dengan cepat status suatu kegiatan sesuai perkiraan perkem-
bangannya.

o Update tasks: memasukkan informasi perkembangan pada suatu
kegiatan.

Update perkembangan dari kegiatan-kegiatan di dalam proyek anda

7.2 Memasukkan Tanggal Mulai dan Seless: yang Sesungguhnya

(Actual) untuk Suatu Kegiatan

Kegiatan yang tidak sesuai jadwal perlu direkam dalam MS Project 2007
untuk perbandingan, dan bagaimana efek terhadap keseluruhan proyek
yang telah direncanakan.

1.

94

Dari menu View, klik Gantt Chart

Dari menu View, point ke Toolbars, kemudian klik Tracking jika belum
dipilih

Di dalam field 7zs% Narme, pilih kegiatan yang ingin diupdate.

Klik To0ls > Tracking > Update Tasks. Dapat pula langsung double-click
di field yang bersangkutan. Atau:

Di dalam Actual, ketik atau pilih tanggal di dalam Stars atau Finish
box. Jika anda memasukkan suatu tanggal finish, yakinkan bahwa
kegiatan tersebut sudah diselesaikan 100%, karena MS Project 2007
mengasumsikan demikian.

¥ Panduan Lengkap Mengelola Proyek dengan Microsoft Project Professional 2007

6.

Untuk studi kasus kita, misalnya kegiatan Pengukuran tanah yang
scharusnya dijadwalkan tanggal 5 Januari 2009 ternyata baru mulai

tanggal 6 Januari 2009.

% Complete: 25

r ACtu&I R e -
mmm §
o Heb o]

Gambar 7.4 Memperbaharui Informasi Penyelesaian Kegiatan di MS Project

Catatan:

Apabila kita memasukkan tanggal Sfart saja dan berbeda dengan
tanggal yang dijadwalkan, berarti ada penundaan (percepatan mungkin
juga) dari jadwal yang ditetapkan.

Apabila kita memasukkan tanggal Finish saja, maka dianggap pekerjaan
selesai 100% pada tanggal tersebut.

Apabila kita memasukkan tanggal Starz dan Finish, maka pekerjaan
dianggap selesai 100% dengan durasi waktu sesuai dengan selisih
kedua tanggal tersebut.

7.3 Mengupdate Perkembangan Kegiatan dalam Persentase

Untuk memudahkan, perkembangan kegiatan dapat juga dimasukkan
dalam bentuk persentase.

Uk W=

Dari menu View, klik Gantt Chart

Di field Tusk Name, klik kegiatan yang ingin diupdate
Klik Task Information, kemudian klik General tab

Di dalam Percent Complete box, ketik nomor persentasenya
Klik OK.
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2. Dari menu Format, point ke dalam Detail Styles, kemudian klik Actual
Work dan tekan tombol Show >> untuk memindahkannya ke sebelah

kanan. Tekan tombol OK.

Gambar 7.5 Memasukkan Penyelesaian Kegiatan dalam Persentase

7.4 Mengupdate Pekerjaan yang Sesungguhnya dengan Periode
Waktu

Kita juga dapat melakukan tracking dari pekerjaan aktual dengan Gambar 7.7 Menentukan Detail Styles dalam Task Usage
menggunakan timephased field di dalam MS Project 2007. Tracking dengan
cara ini menolong anda untuk mengupdate secara periodik karena anda
dapat memasukkan informasi dari hari tertentu di dalam jadwal anda.

1. Dari menu View, Klik Task Usage

3. Tampilan dari Zask Usage akan bertambah di setiap bagian yang
bertuliskan Acz. W. Masukkan informasi kerja aktual yang telah
dilaksanakan oleh resource yang dipilih.

aloloislyls
Iojpinslelslp
sinlsly ey
s loisiolls

4E1(]
.

Gambar 7.6 Tampilan Task Usage

Gambar 7.8 Tumpilan Task Usage Setelah Actual Work Field
Ditambabkan

| . jatan Proyck W 97
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7.5 Melihat Apakah Kegiatan Menggunakan Sumber Daya Lebih
atau Kurang

Varians di dalam jadwal anda dapat bagus atau buruk, tergantung dari tipe
dan keseriusan varians. Suatu kegiatan dengan pekerjaan yang lebih sedikit
dari rencananya, misalnya biasanya adalah berita bagus, tapi ini juga bisa
berarti bahwa sumber daya anda tidak dialokasikan dengan efisien.

1. Dari menu View, klik Gantr Chars
2. Dari menu View, point ke 7able, dan klik Work
3. Bandingkan nilai di dalam Work, Baseline dan Actual  frelds
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Gambar 7.9 Membandingkan Penggunaan Sumber daya

- Teknik percepatan : fast tracking dan crashing
- Updasekinerjasecara cepat (pilih satu menu dan semua yang sebelumnya
dianggap on-time)

7.6 Memasukkan Biaya yang Sesungguhnya Secara Manual

Kita mungkin ingin mengetahui berapa besar biaya yang telah dikeluarkan
dan sebagaimana besar penyimpangan yang terjadi. Dengan mengetahui
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bank: ; snyesuaian selama
hal ini, anda akan dapat melakukan perbarkan dan penyesuaian sel

masih bisa di dalam pelaksanaan proyck.

MS  Project 2007 secara otomatis meng-update biaya} 'a.ktu‘al "da?
perkembangan kegiatan berdasarkan metode accrual yang dipilih dan Juga
tarif dari sumber daya. Untuk memasukkan keadaan yang sesx,.mgguhn)-a,
anda dapat menginput secara manual. Untuk men;gupdat'e biaya secara
manual, anda harus mematikan dulu automatic updating dari actual cost.

1. Dari menu 7vols, pilih Options, kemudian pilih Calculation tab.
2. Hapus Actual costs are always calculated by Microsoft Project check box

3. Klik OK
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Gambar 7.10 Mematikan Penghitungan Biaya Otomatis di MS Project
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Dari menu View, klik Tusk Usage
Dari menu View, point ke Table, kemudian klik Tracking
Jika diperlukan, press 74B untuk melihat Act. Cost field

Di dalam Aez. Cost field, ketik biaya aktual untuk kegiatan yang sedang
diupdate
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Gambar 7.11 Mengisikan Biaya Aktual Suatu Kegiatan

7.7 Memeriksa Apakah Biaya yang Terjadi Melebihi Anggaran
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Gambar 7.12 Informasi Varian Biaya Kegiatan Proyek

7.8 Mengenal Analisis Earned Value

MS Project menghitung biaya dari setiap kerja yang dilakukan oleh sumber
daya, total biaya untuk setiap kegiatan dan sumber daya, dan juga total biaya
proyek. Semua biaya-biaya ini dipertimbangkan sebagai biaya terjadwal
atau projected cost, yang direfleksikan di dalam gambaran yang paling akhir
dari perkembangan proyek.

Dari menu View, klik Gantt Chart

Dari menu View, point ke Table, kemudian Cos?
Bandingkan nilai dari Tota/ Cost dan Baseline fields
Untuk varians, lihat dari nilai di dalam Varignce field

L=
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Apabila informasi dari biaya dan penyelesaian jadwal dari Kegiatan-
kegiatan proyek sudah dimasukkan pada saat pelaksanaan proyek, kita
dapat melakukan analisa perkiraan mengenai nilai - nilai proyek dalam segi
biaya dan waktu dengan menggunakan analisa Earned Value.

Pilihlah menu View > Gantt Chart

Pilihlah menu View > Table dan pilihlah More Tables. Pada tampilan

More Tables pilihlah Earned Value dan tekan tombol Apply.

Tebles: (DTask Ogesouoe

Baseline
Constraint Dates
Cost

Delay.
Famed

Earned Yalue Schedule Indicators
Entry

Export

Hyperlink

Earned Value Cost Indicators

PA_PERT Entry

(o) (]

Gambar 7.13 Memilih Tabe! Earned Value
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Pada tampilan Tabel di Gants Chart akan muncul beberapa kolom dengan
beberapa istilah yang berhubungan dengan Earned Value:
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Gambar 7.14 Tampilan Gantt Chart dengan Earned Value

Catatan:

*  Planned Value - PV (BCWS): Nilai dari kegiatan sesuai yang
dianggarkan.

*  EarnedValue - EV (BCWP): Nilai kegiatan dari hasil pemasukan hasil
perkembangan yang telah dimasukkan,

*  AC (ACWP): 4ctual Cost - biaya sesungguhnya dari kegiatan.

*  SV:Sdhedule Variance - variasi perbedaan jadwal dari yang sesungguhnya
dibandingkan dengan yang terjadwal, negatif berarti kurang baik atau
mengindikasikan potensi keterlambatan.

*  CV: Cost Variance - variasi biaya antara biaya yang sesungguhnya
dibandingkan dengan biaya yang dianggarkan, negatif berarti kurang
baik atau mengindikasikan potensi pembengkakan biaya.
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*  EAC: Estimated At Completion - total biaya yang diharapkan

berdasarkan status sekarang.

7.9 Melihat Biaya Total Proyek

Kita dapat melihat biaya yang paling terakhir, base/ine, atau aktual dan yang
tersisa untuk melihat apakah anda masih di dalam budger yang ditetapkan
sebelumnya. Biaya-biaya ini diupdate setiap kali MS Project menghitung
proyek anda.

1. Dari menu Project, klik Project Information
2. Klik Statistics - semuanya terlihat: current, baseline, dan remaining cost

Gambar 7.15 Melibat Informasi Biaya - Biaya Proyek

7.10 Mengantisipasi Permasalahan Proyek

Apabila selama perencanaan atau pelaksanaan suatu proyek terdapat hal-

hal yang tidak diinginkan sebagai berikut:

*  Lama proyek yang direncanakan terlalu lama dan ingin dipersingkat.

* Setelah data status pekejaan dan biaya dimasukkan ternyata
diperkirakan proyek bakal terlambat dalam penyelesaian.

Untuk menanggulangi hal-hal tersebut maka kita perlu melakukan
beberapa langkah yang dapat kita aplikasikan ke Kegiatan-kegiatan yang
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berada di dalam jalur kritis (critical path) dari proyek. Langkah langkah

tersebut adalah:

1. Fast Tracking. membuat dua buah kegiatan yang scbelumnya
berhubungan secara FS (Finish-to-Start) menjadi agak paralel.
Caranya dengan menambahkan lead time (atau Jag time dengan

nilai negatif) pada kegiatan kedua yang merupakan predecessor dari
kegiatan pertama.

Gambar 7.16 Dua Buah Kegiatan Sebelum Fast Tracking
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Gambar 7.17 Dua Buah Kegiatan Setelah Fast Traking

Catatan:

*  Duabuahkegiatan yang sebelumnya berhubungan FS diubah menjadi
Fast Tracking artinya kegiatan 2 tidak menunggu dulu kegiatan 1
selesai untuk memulai. Hasil kegiatan 1 yang masih berupa draft
dipergunakan sebagai masukan bagi kegiatan 2.

Pelaksanaan Fast Tracking memiliki resiko dimana apabila pada saat
kegiatan 2 sudah dimulai dan ternyata diketemukan kesalahan yang

besar di kegiatan 1, maka apapun yang sudah dikerjakan di kegiatan 2
menjadi tidak berguna.

2. Crashing: memperpendek durasi dari suatu kegiatan dengan kompensasi
penambahan resources di kegiatan tersebut. Contoh kongkretnya adalah
mengharuskan work resource yang ada untuk kerja lembur ataupun
menambahkan work resource baru. Resiko dari penggunaan metode ini
adalah kemungkinan kualitas hasil kerja dari kegiatan yang diperpendek
menjadi lebih buruk meskipun dengan penambahan sumber daya.

-000oo-
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Mengkoordinasikan Beberapa
Proyek Sekaligus

pabila kita melihat studi kasus sebelumnya, sebuah proyek terdiri dari

beberapa summary task dan di dalamnya terdapat serangkaian zask
- task yang dikerjakan oleh satu atau beberapa Resources dalam waktu yang
telah ditentukan. Setiap summary task yang terdapat dalam suatu proyek
dapat dianggap sub-proyek tersendiri yang mungkin dibawah pengelolaan
project manager itu sendiri ataupun orang lain. Kasus lain yang mungkin
terjadi adalah terdapat beberapa proyek yang ditangani suatu perusahaan.
Masing-masing proyek itu bisa berhubungan satu sama lain atau berdiri
sendiri- sendiri. Satu hal yang mengikat masing-masing proyek tersebut
adalah penggunaan sumber daya milik perusahaan yang mungkin sangat
terbatas.

Kasus lain juga mungkin terjadi 2 buah proyek yang berjalan sendiri-
sendiri ternyata memiliki ketergantungan antara satu dengan yang lain.
MS Project 2007 menyediakan sarana bagi pengelolaan proyek yang terdiri
dari beberapa sub-proyek ataupun pengelolaan beberapa proyek sekaligus
yang memakai sumber daya yang terbatas.




8.1 Dependensi Eksternal

Pada studi kasus pembuatan rumah yang sudah kita kerjakan bersama,
terdapat kemungkinan bahwa proyek ini berhubungan dengan proyek lain
dimana satu atau lebih kegiatan di proyek lain tersebut akan mempengaruhi
dimulainya kegiatan dalam proyek pembuatan rumah. Ketergantungan

seperti ini disebut dengan external dependency atau ketergantungan
eksternal.

Misalnya disamping pembangunan rumah terdapat pula proyek
pembangunan PDAM yang berada di depan rumah yang dimulai sejak

- Detil dari proyek PDAM inj adalah sebagai berikut (proyek ini diberi
nama pdam.mpp):

Tabel 8.1 Detil Proyek PDAM

Kegiatan Durasi Pendahulu Resource | Resource
Orang | Material /
Cost
Survey -
Pengukuran 2hari |- Ahli -
Tanah Teknik
Sipil
Pemasangan 1hari | Pengukuran Ahli -
Patok Tanah Teknik
Sipil,
Pekerja 1,
Pekerja 2,
Pekerja 3,
Pekerja 4
Pemeriksaan 0 hari Pemasangan Staf -
Survey Patok PDAM
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Kegiatan Durasi Pendahulu Resource | Resource
Orang Material /
Cost
Penggalian -
Tanah
Pembongkaran | 5 hari | Pemeriksaan Tukang Mesin
Beton Survey Dril Dril (Rp.
250000)
Penggalian 5hari | Pembongkaran | Pekerja1, |-
Beton Pekerja 2,
Pekerja 3,
Pekeja 4
Pengurukan 1hari | Penggalian Pekerja 1, |-
Pasir Pekerja 2,
Pekerja 3,
Pekerja 4
Pemeriksaan Ohari | Pengurukan Staf -
Penggalian Pasir PDAM
Penyambungan - -
Pipa
Penyambungan | 2 hari | Pemeriksaan Pekerja -
Pipa Primer Penggalian Pipa 1,
Pekerja
Pipa 2
3 hari | Penyambungan | Pekerja -
Penyambungan Pipa Primer Pipa 1,
Pipa Sekunder Pekerja
Pipa 2
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Kegiatan Durasi Pendahulu Resource | Resource
Orang Material /
Cost
Pengetesan 2hari | Penyambunga | Staf -
Aliran (mile- | Pipa Sekunder | PDAM,
stone) Pekerja
Pipa 1,
Pekerja
Pipa 2
Pengurukan Penyambungan -
Tanah Pipa
Penimbunan 5 hari | Pengetesan Pekerja 1, |-
Tanah Aliran Pekerja 2,
Pekerja 3,
Pekerja 4
Pengerasan 10 hari | Penimbunan Pekerja 1, -
Tanah Pekerja 2,
Pekerja 3,
Pekerja 4
Pemeriksaan O hari | Pengerasan Staf -
Akhir PDAM
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Adapun tampilan dari proyck PDAM di MS Project 2007 adalah scbagai

berikut:
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Gambar 8.1 Tampilan Proyek PDAM di MS Project 2007

Apabila kita kembali ke proyek pembuatan rumah yang telah kita buat
sebelumnya, kita mengetahui bahwa kegiatan Pemasangan Jalur PDAM
di proyek MyProject.mpp tergantung pada kegiatan Pengetesan Aliran di
proyek PDAM.mpp . Ini berarti terdapat ketergantungan eksternal antara
kedua kegiatan tersebut.

Cara untuk menunjukkan ketergantungan eksternal adalah:

1. Bukalah kedua berkas
MyProject.mpp.

2. Lihatlah pada nomor berapa kegiatan di proyek PDAM dimana
kegiatan Pengetesan Aliran berada, yaitu nomor 13.

3. Pada proyek MyProject.mpp, klik dobel kegiatan tersebut untuk
mendapatkan tampilan Zask Information, dan pilihlah Taé Predecessors.
Tambahkan ketergantungan eksternal dengan menuliskan di kolom
ID nama berkas proyeknya yaitu PDAM dan kemudian ditambah
garis miring dan nomor tugasnya yaitu 13.

secara bersamaan yaitu PDAM.mpp dan
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Gambar 8.2 Menambahkan Ketergantungan Efksternal

Apabila kita melihat tampilan Ganst Chart pada MyProject maka terdapat
sebuah kegiatan yang berwarna abu-abu yang merupakan kegiatan di

proyek PDAM. Demikian juga sebaliknya di proyek PDAM.
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Gambar 8.3 Tampilan Dependensi Eksternal di MyProject
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Gambar 8.4 Tampilan Dependesnsi Eksternal di PDAM

Catatan:

+  Dependensi eksternal dapat mengubah jadwal proyek, misalnya pada
proyek PDAM terdapat keterlambatan sehingga kegiatan Pengetesan
Aliran mengalami kemunduran, maka kegiatan Pemasangan Jalur
PDAM di proyek MyProject juga akan terpengaruh.

8.2 Pengenalan Master Project - Sub Project

MS Project 2007 juga memiliki kemampuan untuk menggabungkan
beberapa proyek menjadi satu proyek, untuk mengkoordinasikan jadwal
dan juga sumber daya yang ada.

1. Buka menu File > New untuk dijadikan master project

2. Dari menu View, klik Gantt Chart

3. Di dalam field 7usé Name, klik baris di mana satu proyek ingin
dimasukkan.

4. Dari menu Insert, pilih Project

5. Cari file project yang sudah dipersiapkan sebelumnya yang akan
dianggap sebagai sub-project dari master project ini.
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6. Klik file yang diinginkan, dan klik Insers

7. Setiap kali kita mengklik menu File > Save di master project, file-
file sub-project yang telah dimasukkan akan juga di-update. Jika
anda tidak menginginkan file aslinya diupdate dengan perubahan-
perubahan tersebut, hapus box Link to Project. Caranya adalah dari
Task Information pilih Advanced tab. Kemudian di Inserted Project
Information, un-checked Link project.

Catatan

*  Sub-projects diperlakukan seperti rangkuman kegiatan-kegiatan di
dalam master project. Sama seperti kegiatan-kegiatan yang dapat
disusun dalam suatu outline, demikian juga dengan proyek.

*  Ketika mengkonsolidasikan proyek-proyek menjadi satu master project,
sumber daya-sumber daya tetap ditinggalkan di dalam file proyek
individual. Anda tidak dapat mengatur satu sumber daya di satu
proyek ke yang lainnya. Tapi sumber daya-sumber daya tersebut, dapat
digabungkan ke dalam suatu shared resource pool (pilih menu Tools >
Resources Sharing > Share Resources)Ini dapat dilihat dari Help.

8.3 Master Project - Sub Project dengan Resource Terpisah

Sebagai contohnya dalam proyek pembuatan rumah yang sudah dikerjakan

ternyata bagian dari proyek yang cukup besar yaitu proyek pembangunan

perumahan, yang terdiri dari 3 sub proyek yaitu:

1. Proyek Pembebasan Lahan

2. Proyek Pembangunan Rumah (dalam hal ini misalnya 3 buah rumah
saja).

3. Proyek Pembangunan Jalan

112 ® Panduan Lengkap Mengelola Proyek dengan Microsoft Project Professional 2007

Untuk Proyck Pembebasan Lahan terdapat informasi kegiatan sebagai

berikut:
Tabel 8.2 Detil Kegiatan Proyek Pembebasan Lahan
Kegiatan Durasi | Pendahulu Resource Resource
Orang Material /
Cost
Penyiapan -
Lahan
Pengukuran 2d - Tukang Ukur, -
Lahan Mandor 1,
Arsitek
Pembersihan | 3d Pengukuran | TukangLahan1, | -
Lahan Lahan Tukang Lahan 2,
Tukang Lahan 3
Pemagaran 2w Pembersihan | Tukang Bata 1, | Batu Kali (10
Lahan Lahan Tukang Bata 2, | truk), Pasir
‘Tukang Bata 3, | (10 truk),
Asisten Tukang | Semen (100
1, Asisten sak), Batako
Tukang 2, (10000 buah)
Asisten Tukang
3, Mandor 2
Pengecekan Mile- | Pemagaran Arsitek, Mandor
Lahan stone Lahan 1, Mandor 2
Pengerasan -
Lahan
Pengurukan 3w Pengecekan Tukang Lahan | Truk (Rp.
Lahan Lahan 1, Tukang 150000), Pasir
Lahan 2, Supir (12 truk)
| Truk 1
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Untuk Proyck Pembangunan Jalan terdapat informasi kegiatan sebagai
Yy I I g

Kegiatan Durasi | Pendahulu Resource Resource
Orang Material /
Cost
Penyetoman 1w Pengurukan | Tukang Stom, Stom (Rp.
Lahan Tukang Lahan 200000)
1, Tukang
Lahan 2
Pemeriksaan Mile- | Penyetoman | Arsitek, Mandor | -
Pengerasan stone 1, Mandor 2
Pematokan
Kavling
Pengukuran 1d Pemeriksaan Tukang Ukur,
| Kavling Pengerasan Asisten Tukang
1, Asisten
Tukang 2
Pemasangan | 2d Pengukuran | Tukang Ukur, Patok (100
Patok Kavling Asisten Tukang | buah)
1, Asisten
Tukang 2,
Asisten Tukang
3
Pemeriksaan | Mile- | Pemasangan | Arsitek, Mandor | -
Akhir stone | Patok 1, Mandor 2
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berikut:
Tabel 8.3 Detail Kegiatan Proyek Pembangunan Jalan
Kegiatan Durasi | Pendahulu | Resource Orang Resource
Material /
Cost
Penyiapan - - -
Lahan Jalan
Pengukuran 2d - Tukang Ukur, -
Bakal Jalan Arsitek, Mandor
2
Pemasangan 3d Pengukuran | Tukang Ukur, Patok (100
Patok Jalan Bakal Jalan Tukang Bata 1, | buah)
Tukang Bata 2,
Tukang Bata 3
Pemeriksaan Mile- | Pemasangan | Arsistek, -
Lahan Jalan stone Patok Jalan Mandor 2
Pengerasan -
Jalan ,
Penyusunan 1w Pemeriksaan | Asisten Tukang | Truk (Rp. *
Batu Jalan Lahan Jalan | 1, Asisten 750000), Batu
Tukang 2, Kali (100 truk)
Asisten Tukang
3, Supir Truk
Penghalusan 1w Pengerasan | Tukang Bata 1, | Pasir (50 truk)
Permukaan Jalan Tukang Bata 2,
Jalan Tukang Bata 3,
Asisten Tukang
1, Asisten
Tukang 2,
Asisten Tukang 3
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j
Kegiatan Durasi | Pendahulu | Resource Orang Renource Buatlah bahwa proyek tersebut dimulai pada tanggal 1 Desember
Material / 2008.
Penyetoman 2w Penghalusan | Tukang Stom Stom (Rp. : e e e
Jalan Permukaan 500000) i Gl 5 i i ogiine
Pemeriksaan Mile- | Penyetoman | Arsitek, Mandor | - e ""'""'"-TI:,.'-::
Jalan stone | Jalan 1, Mandor 2 R il ' e i o "E;::.
Pengaspalan ST ITEERERD NIEW |
Jalan —
Hotmix Jalan | 2w Pemeriksaan | Tukang Bata 1, | Aspal (50 Il
Jalan Tukang Bata 2, | drum), Pasir 1
Tukang Bata 3, | (25 truk)
Asisten Tukang P
1, Asisten e *
Tukang 2, Gambar 8.5 Gantt Chart Proyek Pembebasan Lahan
Asisten Tukang
3, Tukang Stom 2. Buatlah juga proyek pembangunan jalan dalam MS Project 2007 yang
Pengecatan 1w Hotmix Jalan | Asisten Tukang | Cat (25 kaleng) diberi nama MyJalan.mpp yang dimulai 2 Februari 2009.
Marka Jalan 1, Asisten
Tukang 2, i“é‘“,‘. o oy
Asisten Tukang 3 » .
Pemasangan 3d Hotmix Jalan | Asisten Tukang | Papan Nama | P el ’:wv:.:::u:ﬂ;c: : :ff
Nama Jalan 1, Asisten Jalan (25 buah) k ‘ ;E v v o ‘é: ' ‘
g e T
Asisten Tukang 3 v %mmum,‘;,m
Pemeriksaan Mile- | Pemasangan | Arsitek, Mandor 1 FEE";%, =l E.':.’.‘.L‘..“:.L‘.‘.’.',T.:
Akhir stone Nama Jalan, |1, Mandor 2 —a :
Pengecatan —
Marka Jalan
|
Langkah-langkahnya adalah sebagai berikut: _ ‘ |
1. Buatlah proyek yang diberi nama Mydrea.mpp yang isinya adalah i e i BRI
kegiatan proyek pembebasan Lahan yang terdapat pada tabel diatas. | Gambar 8.6 Ganst Chart Proyek Pembangunan Jalan |
| [
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3. Kopilah berkas proyek MyProject.mpp yang dipakai sehagai studi kasus
menjadi 3 buah dan gantilah menjadi:
a.  MyProject1.mpp : seperti proyek sebelumnya
b.  MyProject2.mpp : seperti proyek sebelumnya dengan permulaan
proyek dimulai 2 Maret 2009.
¢ MyProject3.mpp: seperti proyek sebelumnya dengan permulaan
proyek dimulai 4 Mei 2009.

Pilih di Toolbar yang baru yang bernama Adjust Dates,gantilah informasi
permulaan proyek menjadi 3/2/2009 (Tanggal 2 dipilih karena hari
Senin yang sama seperti hari permulaan proyek sebelumnya).

Original project start date:
1/5/09 |

Cancel I

Enter a riew project start date:
[312109

Catatan: Cara mengubah mengubah project start date secara keseluruhan:
*  Piliblah menu View > Toolbars > Analysis, pada bagian Tbolbar akan
muncul koleksi Toolbar yang baru yang akan dipergunakan.

‘,,\:,. ;,- it ;,,»‘,q-w s s m

Gambar 8.9 Mengubah Tanggal Permulaan Proyek

— - +  Tanggal mulai proyek sekarang sudah berubah menjadi tanggal 2
Gambar 8.7 Tvolbar untuk Melakukan Analisis Proyek Maret 2009.
+  Lakukan hal serupa untuk MyProject3.mpp dengan permulaan proyek

*  Bukalah berkas MyProject2. mpp yang merupakan kopi dari MyProject. tanggal 4 Mei 2009 (pilih hari Senin).

mpp yang ingin kita ubah tanggal proyeknya dari semula 5 Januari
2009 menjadi 2 Maret 2009.

* Pilihlah menu View > Gantt Chart, blok semua kegiatan dengan
menggunakan mouse. Klik kanan dan pilihan Zask Information.
Isikanlah 0% untuk Percent complete dan kemudian tekan tombol OK.

4. Bukalah proyek baru yang diberi nama MyPerumahan.mpp.Didalamnya
terdapat Kegiatan-kegiatan berikut yang merupakan kegiatan di
proyek itu sendiri dan juga sub - sub proyek.

Tabel 8.4 Detil Kegiatan Proyek Perumahan

: Kegiatan Durasi Pendahulu | Resource | Resource
| Orang | Material
P / Cost
uchtaskga HE
Tt Peresmian Milestone | - Owner -
Pembukaan
RN Perumahan
= Sub Proyek: Peresmian
- Pembebasan Pembukaan
Gambar 8.8 Mengbapus Informasi Penyelesaian Kegiatan pada Suatu Proyek Lahan Perumahan
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Kegiatan

Durasi

Pendahulu

Resource
Orang

Resource
Material
/ Cost

Sub Proyek :
Rumah 1

Sub Proyek :
Rumah 2

Sub Proyek :
Rumah 3

Sub Proyek:

Pembangunan
Jalan

Grand

Launcing

Milestone

Sub Proyek:
Pembangunan
Jalan

Caranya adalah sebagai berikut:

1. Bukalah MS Project 2007 seperti biasa, atau kalau sudah terbuka

pilihlah File > New.

Pada menu Project > Project Information, masukkan project start date
yaitu tanggal 1 Desember 2008 (sesuai dimulainya sub-project yang
pertama) atau lebih awal dari itu.

Lakukan perubahan mata uang pada proyek ini yang semula
menggunakan Dollar Amerika menjadi Rupiah.

Tuliskan kegiatan yang pertama yaitu Peresmian Pembukaan Perumaban
dan buatlah durasinya nol untuk membuatnya menjadi Milestone.
Untuk memasukkan Sub Project, pilih baris kegiatan dibawahnya dan
pilih menu Insert > Project. Carilah Sub Project yang ingin dimasukkan
pertama yaitu MyArea.mpp, kemudian pilih OK.
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Gambar 8.10 Memasukkan Sub-Project ke Dalam Master Project

Lakukan hal serupa untuk MyProjectl.mpp, MyProject2.mpp,

MyProject3.mpp, dan MyJalan.mpp

Masukkan kegiatan terakhir yaitu Grand Launching, hubungkan
dengan pendahulunya yaitu Sub Project Pembangunan Jalan.

Pilih File > Save dan simpanlah sebagai MyPerumahan.mpp . Tampilan
proyek perumahan adalah sebagai berikut:

|¢‘N 1v-u—- ‘nau Ll o - 1Ed b ; -
o s oa e o Giera]| WonIAED. Won T5ER 7] ) ! T ’
R wyhea 18 daye? Aom 121128 Yod 12009 éﬁ——w ! : | |
T wyProjea 1.5 days| Tua 1508 Fri 62409 [ Cm——————m— :
U MyProjet 1.5 days| Mon /208 Vad §/17.09 ) . ) i |
' MyProgear 1.5 duys | Won 7409 T 812009 | | im————
< ydaian 43 duys Vad 811900 Fri 107608 ; : w—-—?‘m
GrandLaurching Odays”Hriionace " Fa1oANOH S i | | |
i e i i &
"""" = ! L
e . . e | i | i
! | | i i i
! . w
; I I i |
= o | Lo
| \ \ | |
b | .
{ | J | ‘
N | B
- WMJ M i | ‘ | - ‘ ‘,E“H

Gambar 8.11 Gantt Chart Master Project Perumahan
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Catatan:

*  Untuk melihat tugas - tugas didalam masing - masing Sub Project nya
caranya dengan mengklik tanda + disebelah kiri Sué Project Tersebut.

*  Lihatlah bagian Resource Sheet untuk mencari kemungkinan Resource
Ower Allocation (yang berwarna merah). Lakukanlah Resource Leveling
yang sudah dicontohkan di bab sebelumnya).

*  Sebuah resource, meskipun namanya sama akan muncul beberapa kali
tergantung di proyek mana saja resource tersebut dipergunakan.

*  Semua perubahan yang dilakukan di MyPerumahan.mpp akan juga
berakibat perubahan di masing-masing Sub Project yang terkait
dengannya. Demikian juga berlaku sebaliknya.

8.4 Pengenalan Master Project - Sub Project dengan Resource
Pooling

Apabila terdapat banyak proyek yang berjalan dan jumlah Resources-nya
terbatas dan ingin dikontrol dengan ketat, penggunaan Resource Pooling akan
sangat bermanfaat. Dengan Resource Pooling semua Proyek akan mengacu
pada daftar resource yang sudah disiapkan (sebuah berkas MS Project 2007
yang isinya hanya daftar resource saja). Dengan cara ini konflik resource dari
berbagai macam proyek dapat dihindari.

Cara - cara penggunaan Resource Pooling:

1. Buatlah berkas baru dari MS Project. 2007

2. Pilihlah View > Resource Sheet, isikanlah semua Resources yang dimiliki
yang akan dipergunakan oleh semua proyek. Simpanlah berkas ini
misalnya bernama MyPool. mpp.

3. Buatlah proyek baru yang lengkap, pilihlah menu 7Tvols > Resource
Sharing > Share Resources. Pilihah MyPool sebagai sumber Resources
yang akan dipakai.
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@iwre Resources '

Resources for ‘MyArea'
Q Use awn resources
(® Use resources

From: | MyPool vl

On conflict with calendar or resource information
(Y Pool takes precedence
{C sharer takes precedence

(e )] o) (comel

Gambar 8.12 Menghubungkan Sebuah Proyek ke Resource Pool

Catatan:

Berkas yang dipergunakan sebagai resource pooling tidak harus berada
dalam satu folder dan bahkan bisa dalam komputer yang berbeda
dalam satu jaringan. Agar berkas tersebut muncul sebagai pilihan di
gambar 8.10 maka harus dibuka terlebih dahulu.

Setelah itu maka setiap kali kita melihat Resource yang dimiliki project
sesungguhnya adalah resource yang dipakai bersama - sama.
Kelemahan teknik ini adalah apabila Data Resource sangat banyak dan
jumlah proyek yang terhubung juga banyak, maka kinerja dari MS
Project bisa terganggu (lebih lambat).

Kelemahanlainnyaadalah kita tidak bisa melihat prosentasi penggunaan
dari masing - masing Resources untuk masing - masing proyek yang
memakainya (hanya memperlihatkan jumlah total penggunaannya
saja tanpa perincian).

-00000-
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Laporan Proyek
dan Penutupan Proyek

Setelah segala tahapan proyek mulai dari perencanaan dan pelacakan
sudah dijalankan, maka langkah selanjutnya adalah membuat laporan
dan sekaligus juga menutup proyek. Proses mencetak laporan di MS Project
2007 cukup mudah dan juga memiliki dua jenis laporan yaitu laporan
dokumen dan laporan visual. Sedangkan untuk menutup proyek itu sendiri
merupakan langkah yang sangat penting dalam rangka tertib administrasi
dan juga mendapatkan pelajaran sehingga proyek-proyek selanjutnya akan
lebih baik lagi.

9.1 Membuat Laporan Visual Proyek

e

Laporan visual dari MS Project 2007 dapat diakses dari menu Reporss >
Visual Reports.




Fisuni Reports - Croute Hopart ST
Seloct Ternplate
Show report templates aested in:

| Jeskounmary | ResouceSummary [ Assk Sunmary |
M| JakUswe | ResowcsUssge | Assorment Usage |
£] Baseline Cost Report ———
£3] Baseline Work Report
Budget Work Report
) Cash Flow Repart Manage Template... .
£Z]Eamed vake Over Time Report Sl e e
Resource Cost Summary Report >
Resource Remaining Work Report
Resource Work Avadablity Report
Resource Work Summary Report

Select lovel of Usage data to Indude I the report: (Woeks — [v]
{Tinckude report templates from: L e

i P ﬁgd\iu_

Gambar 9.1 Piliban Visual Reports

Laporan yang dihasilkan akan berupa daza cube (table dimensi kubus) yang
akan ditampilkan secara otomatis di MS Excel lengkap dengan sajian
grafisnya berupa diagram.

Lt

f~\>‘,‘ir—b,4Fr*‘~_'I

Baseline Cost Report e oy
e 2]
M
=} # )T Wby Cobonds
Ehaschine Cost I Cost O Actal Cost #[Gwe
fr N
‘!r.um
;’-.-ldﬂ"
— v'ﬁ-ﬁ{hﬂ >
o ] ) a3

Gambar 9.2 Tumpilan Baseline Cost Report di MS Excel

126 W Panduan Lengkap Mengelola Proyek dengan Microsoft Project Professional 2007

i85

9.2 Membuat Laporan Dokumen Proyek

[Laporan lain yang bisa dibuat adalah laporan berbentuk dokumen yang
dapat diakses di menu Repor > Reports. Terdapat enam jenis laporan yang

dapat dibuat.

Owerview Reports berisi laporan- laporan tentang proyek secara garis besar.

Gambar 9.3 Piliban Laporan Dokumen

Terdapat lima jenis laporan yang dapat dihasilkan.

Project Summary.

Top-tevel Tasks

Critical Tasks

Gambar 9.4 Piliban Overview Reports
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Current  Activity  Reports  melaporkan  Kegiatan-kegiatan — lengkap
dengan statusnya sampai dengan saat ini (saat terakhir status proyck

diperbaharui).

" Completed Tasks Shouid Have Started

Gambar 9.5 Piliban Current Activity Reports

Cost Reports akan melaporkan segala macam yang berhubungan dengan
biaya proyek.

(Overbudget - Eged Vakie

Gambar 9.6 Piliban Cost Reports

Assignment Reports akan melaporkan segala yang berhubungan dengan
resources dan penggunaannya.
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Gambar 9.7 Pilihan Assignment Reports

Workload Report melaporkan tentang penggunaan sumber daya pada
Kegiatan-kegiatan di proyek.

Gambar 9.8 Pilihan Workload Reports

Laporan jenis lainnya dapat kita hasilkan dengan memilih Custom Reports.

Budget Report
Cash Flow
Completed Tasks

Critical Tasks

Crosstab

Earned Yalue

| Milestones
Overallocated Resources
Overbudget Resources
dget Tasks

Gambar 9.9 Piliban Custom Reports
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9.3 Menutup Proyek

Tahapan paling akhir dari suatu proyek adalah fase penutupan. Tahapan ini
dilaksanakan setelah produk hasil dari proyek beserta semua pelengkapnya
sudah diserahkan kepada konsumen. Beberapa kegiatan yang dianjurkan
pada tahapan ini adalah:

1. Memperbaharui status terakhir dari MS Project 2007, kalau perlu
simpan sebagai baseline terakhir.

2. Finalisasi dan pengarsipan dengan baik semua dokumentasi dari
proyek sehingga dapat menjadi referensi dari proyek selanjutnya.

3. Mengadakan pertemuan yang dihadiri semua anggota proyek yang
bertujuan untuk menarik pelajaran berharga mengenai segala sesuatu
yang masih belum berjalan dengan benar sehingga pada proyek
selanjutnya akan lebih baik.
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